summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Gaifas2020-08-24 11:36:25 +0200
committerLorenzo Gaifas2020-08-24 11:36:25 +0200
commit09c187f65a81f9390b6ae02582eac8d94a952dd8 (patch)
tree7c3928cdd32f2666f77c616675f038d0068984d1
parent215941d6c9263276b62aefa6af2bf25c17dbdb89 (diff)
downloadaur-09c187f65a81f9390b6ae02582eac8d94a952dd8.tar.gz
removed outdated patch
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--apbstools_tcltk8.6.patch106
3 files changed, 9 insertions, 121 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dda875fc40f1..e49a0b50eefa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,13 +19,13 @@ pkgbase = pymol-git
depends = tcsh
optdepends = python-pmw: pmw based UI
optdepends = python-pyqt5: Qt5 based UI
- optdepends = ffmpeg
- provides = pymol
+ optdepends = ffmpeg: MPEG encoding
+ provides = pymol=r4707.7b4e2af9
conflicts = pymol
source = pymol::git+https://github.com/schrodinger/pymol-open-source.git
source = pymol.png::https://c.fsdn.com/allura/p/pymol/icon
- source = apbstools_tcltk8.6.patch
- sha512sums = SKIP
- sha512sums = 39917c1dc80cd6a59e8f6b3ea49a59491eaf23d14e32ac264f6d71f33007f686deb6a66e50e7f20ef9df5337038e3572b018633c361460d5ee0c1d8f0a8259d1
- sha512sums = 90fce6d3c4364cd775b44bdd9013a08f26392339bec40ecd749220b3d11391381f5b159734bdb2e2ac675fbc016a6a1b9c4cec2fa8c9c0226609a5f09b610b9c
+ md5sums = SKIP
+ md5sums = a6b62ae41658a772f75b3b123a8e5c0b
+
pkgname = pymol-git
+
diff --git a/PKGBUILD b/PKGBUILD
index 876a113b3e7b..e525b7cb814b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=pymol
pkgname="${_name}-git"
-pkgver=r4707.7b4e2af9
+pkgver=r4806.c7095ec2
pkgrel=1
pkgdesc="Molecular visualization system on an Open Source foundation"
arch=('x86_64')
@@ -16,11 +16,9 @@ optdepends=('python-pmw: pmw based UI'
conflicts=('pymol')
provides=("${_name}=${pkgver}")
source=(${_name}::"git+https://github.com/schrodinger/pymol-open-source.git"
- ${_name}.png::"https://c.fsdn.com/allura/p/pymol/icon"
- "apbstools_tcltk8.6.patch")
+ ${_name}.png::"https://c.fsdn.com/allura/p/pymol/icon")
md5sums=('SKIP'
- 'a6b62ae41658a772f75b3b123a8e5c0b'
- '138550367b74fd62a7c7bc48d339eb2d')
+ 'a6b62ae41658a772f75b3b123a8e5c0b')
pkgver() {
cd "${srcdir}/${_name}"
@@ -35,10 +33,6 @@ prepare() {
# suppress non-zero exit code that breaks makepkg
sed -i '/sys.exit/ s,2,0,' "${srcdir}/${_name}/setup.py"
-
- # fix FS#39526
- cd "${srcdir}/${_name}"
- patch -p0 -i "${srcdir}/apbstools_tcltk8.6.patch"
}
build() {
diff --git a/apbstools_tcltk8.6.patch b/apbstools_tcltk8.6.patch
deleted file mode 100644
index f60b5c78a69a..000000000000
--- a/apbstools_tcltk8.6.patch
+++ /dev/null
@@ -1,106 +0,0 @@
---- modules/pmg_tk/startup/apbs_tools.py.orig 2014-05-14 01:07:32.000000000 +0400
-+++ modules/pmg_tk/startup/apbs_tools.py 2014-05-14 01:15:35.090032827 +0400
-@@ -612,7 +612,8 @@
- # Set up the Main page
- page = self.notebook.add('Main')
- group = Pmw.Group(page,tag_text='Main options')
-- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
- self.selection = Pmw.EntryField(group.interior(),
- labelpos='w',
- label_text='Selection to use: ',
-@@ -856,7 +864,8 @@
- page.grid_columnconfigure(5,weight=1)
- page = self.notebook.add('Program Locations')
- group = Pmw.Group(page,tag_text='Locations')
-- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
- def quickFileValidation(s):
- if s == '': return Pmw.PARTIAL
- elif os.path.isfile(s): return Pmw.OK
-@@ -955,7 +964,8 @@
-
- page = self.notebook.add('Temp File Locations')
- group = Pmw.Group(page,tag_text='Locations')
-- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
- self.pymol_generated_pqr_filename = Pmw.EntryField(group.interior(),
- labelpos = 'w',
- label_pyclass = FileDialogButtonClassFactory.get(self.setPymolGeneratedPqrFilename),
-@@ -1003,17 +1013,20 @@
- page = self.notebook.add('Visualization (1)')
- group = VisualizationGroup(page,tag_text='Visualization',visgroup_num=1)
- self.visualization_group_1 = group
-- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
-
- page = self.notebook.add('Visualization (2)')
- group = VisualizationGroup(page,tag_text='Visualization',visgroup_num=2)
- self.visualization_group_2 = group
-- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
-
- # Create a couple of other empty pages
- page = self.notebook.add('About')
- group = Pmw.Group(page, tag_text='About PyMOL APBS Tools')
-- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
-+ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
- text = """This plugin integrates PyMOL (http://PyMOL.org/) with APBS (http://www.poissonboltzmann.org/apbs/).
-
- Documentation may be found at
-@@ -2271,7 +2284,8 @@
- self.update_buttonbox = Pmw.ButtonBox(self.mm_group.interior(), padx=0)
- self.update_buttonbox.pack(side=LEFT)
- self.update_buttonbox.add('Update',command=self.refresh)
-- self.mm_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=TOP)
-+ #self.mm_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=TOP)
-+ self.mm_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
-
- self.ms_group = Pmw.Group(self.interior(),tag_text='Molecular Surface')
- self.ms_buttonbox = Pmw.ButtonBox(self.ms_group.interior(), padx=0)
-@@ -2322,7 +2336,8 @@
- bars = (self.mol_surf_low,self.mol_surf_middle,self.mol_surf_high)
- Pmw.alignlabels(bars)
- for bar in bars: bar.pack(side=LEFT)
-- self.ms_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
-+ #self.ms_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
-+ self.ms_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
-
- self.fl_group = Pmw.Group(self.interior(),tag_text='Field Lines')
- self.fl_buttonbox = Pmw.ButtonBox(self.fl_group.interior(), padx=0)
-@@ -2337,7 +2352,8 @@
- text = """Follows same coloring as surface.""",
- )
- label.pack()
-- self.fl_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=TOP)
-+ #self.fl_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=TOP)
-+ self.fl_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
-
- self.pi_group = Pmw.Group(self.interior(),tag_text='Positive Isosurface')
- self.pi_buttonbox = Pmw.ButtonBox(self.pi_group.interior(), padx=0)
-@@ -2356,7 +2372,8 @@
- entryfield_validate = {'validator' : 'real', 'min':0}
- )
- self.pos_surf_val.pack(side=LEFT)
-- self.pi_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
-+ #self.pi_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
-+ self.pi_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
-
- self.ni_group = Pmw.Group(self.interior(),tag_text='Negative Isosurface')
- self.ni_buttonbox = Pmw.ButtonBox(self.ni_group.interior(), padx=0)
-@@ -2375,7 +2392,8 @@
- entryfield_validate = {'validator' : 'real', 'max':0}
- )
- self.neg_surf_val.pack(side=LEFT)
-- self.ni_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
-+ #self.ni_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
-+ self.ni_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
-
-
-