summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Lisowski2020-09-20 13:43:39 +0200
committerMichał Lisowski2020-09-20 13:43:39 +0200
commit09c64ec3267e6e82903ad29f41aa03593b3de4ca (patch)
treefeb16fac7d0b27b311f4dbfaec15e00933347a94
parent9cdcb9fd83a890e45a3ad1d45f80f9307218ebca (diff)
downloadaur-09c64ec3267e6e82903ad29f41aa03593b3de4ca.tar.gz
Updated to 0.5.3, with python3 support
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD59
-rw-r--r--cracklib.patch33
-rw-r--r--crypto.patch142
-rw-r--r--gnome-python.patch28
-rw-r--r--revelation.install26
6 files changed, 24 insertions, 293 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98ed2f98cef5..88557bd52ac7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,16 @@
pkgbase = revelation
pkgdesc = A password manager for the GNOME desktop
- pkgver = 0.4.14
- pkgrel = 7
+ pkgver = 0.5.3
+ pkgrel = 1
url = http://revelation.olasagasti.info/
- install = revelation.install
- arch = i686
arch = x86_64
license = GPL
- makedepends = intltool
- depends = gnome-python>=2.10
- depends = python2-crypto
- depends = python2-crack
- depends = desktop-file-utils
- depends = python2
- depends = hicolor-icon-theme
- depends = pkg-config
- depends = python2-dbus
- source = https://bitbucket.org/erikg/revelation/downloads/revelation-0.4.14.tar.bz2
- source = cracklib.patch
- source = gnome-python.patch
- source = crypto.patch
- sha256sums = 2ab3d1d8bcc2f441feb58122ee6a0fe4070412228194843a180a7b1c9e910019
- sha256sums = f5cebe215115cb5a78f470da9753be3c5ff99095f28ab57ae45d2d03b3a686d6
- sha256sums = b2803f3f0ab344453fc4f82c90c8eefe99e1b23f77de09bf598741c73458a044
- sha256sums = 6ed410e83810a6cb44ac0e4828ba686fe8ee1a9a7743d7240dcdc038ad15927c
+ depends = gtk3
+ depends = python-gobject
+ depends = libpwquality
+ depends = python-pycryptodomex
+ source = https://github.com/mikelolasagasti/revelation/releases/download/revelation-0.5.3/revelation-0.5.3.tar.xz
+ sha256sums = 8976644b8904db179f5927ea9045c5082faefdfecf079845ca081321935bdfac
pkgname = revelation
diff --git a/PKGBUILD b/PKGBUILD
index 0ce2691e4dc7..a9b6ffef3c16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,55 +2,28 @@
# Contributor: Thomas Hebb <tommyhebb@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=revelation
-pkgver=0.4.14
-pkgrel=7
+pkgver=0.5.3
+pkgrel=1
pkgdesc="A password manager for the GNOME desktop"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL')
-depends=('gnome-python>=2.10' 'python2-crypto' 'python2-crack' 'desktop-file-utils' 'python2' 'hicolor-icon-theme' 'pkg-config' 'python2-dbus')
-makedepends=('intltool')
-install=revelation.install
+depends=('gtk3' 'python-gobject' 'libpwquality' 'python-pycryptodomex')
url="http://revelation.olasagasti.info/"
-source=("https://bitbucket.org/erikg/revelation/downloads/revelation-${pkgver}.tar.bz2"
- 'cracklib.patch'
- 'gnome-python.patch'
- 'crypto.patch')
-sha256sums=('2ab3d1d8bcc2f441feb58122ee6a0fe4070412228194843a180a7b1c9e910019'
- 'f5cebe215115cb5a78f470da9753be3c5ff99095f28ab57ae45d2d03b3a686d6'
- 'b2803f3f0ab344453fc4f82c90c8eefe99e1b23f77de09bf598741c73458a044'
- '6ed410e83810a6cb44ac0e4828ba686fe8ee1a9a7743d7240dcdc038ad15927c')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- patch -uNp1 -i "${srcdir}/cracklib.patch"
- patch -uNp1 -i "${srcdir}/gnome-python.patch"
- patch -uNp1 -i "${srcdir}/crypto.patch"
-
- ./autogen.sh
-}
+source=("https://github.com/mikelolasagasti/revelation/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('8976644b8904db179f5927ea9045c5082faefdfecf079845ca081321935bdfac')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
- --libexecdir=/usr/lib/revelation \
- --localstatedir=/var \
- --disable-mime-update --disable-desktop-update \
- --with-python-include=/usr/include/python2.7
- make
+ cd "${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --disable-desktop-update \
+ --disable-mime-update
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
-
- sed -i "s|#!/usr/bin/\(env \)\?python$|#!/usr/bin/\1python2|" \
- $pkgdir/usr/bin/revelation \
- $pkgdir/usr/lib/python2.7/site-packages/revelation/bundle/PBKDFv2.py
-
- install -m755 -d "${pkgdir}/usr/share/gconf/schemas"
- gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${pkgname}.schemas" --domain revelation ${pkgdir}/etc/gconf/schemas/*.schemas || return 1
- rm -f ${pkgdir}/etc/gconf/schemas/*.schemas
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
+
diff --git a/cracklib.patch b/cracklib.patch
deleted file mode 100644
index b07723515ef2..000000000000
--- a/cracklib.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naur revelation-0.4.14.orig/configure.ac revelation-0.4.14/configure.ac
---- revelation-0.4.14.orig/configure.ac 2012-08-14 01:08:27.190736795 -0400
-+++ revelation-0.4.14/configure.ac 2012-08-14 01:43:35.396873763 -0400
-@@ -24,7 +24,7 @@
- RVL_PYTHON_MODULE(gobject, yes)
- RVL_PYTHON_MODULE(pango, yes)
- RVL_PYTHON_MODULE(dbus, yes)
--RVL_PYTHON_MODULE(cracklib, yes)
-+RVL_PYTHON_MODULE(crack, yes)
-
-
- dnl Enable applet installation
-diff -Naur revelation-0.4.14.orig/src/lib/util.py revelation-0.4.14/src/lib/util.py
---- revelation-0.4.14.orig/src/lib/util.py 2012-08-14 01:08:27.194070085 -0400
-+++ revelation-0.4.14/src/lib/util.py 2012-08-14 01:43:53.473311172 -0400
-@@ -23,7 +23,7 @@
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
- #
-
--import datetime, cracklib, gettext, math, os, random, shlex, string, StringIO, traceback
-+import datetime, crack, gettext, math, os, random, shlex, string, StringIO, traceback
-
- _ = gettext.gettext
-
-@@ -94,7 +94,7 @@
- # check password with cracklib
- try:
- if len(password) < 100:
-- cracklib.FascistCheck(password)
-+ crack.FascistCheck(password)
-
- except ValueError, reason:
-
diff --git a/crypto.patch b/crypto.patch
deleted file mode 100644
index 987370afdfd6..000000000000
--- a/crypto.patch
+++ /dev/null
@@ -1,142 +0,0 @@
-diff -Naur revelation.orig/src/bundle/AfSplitter.py revelation/src/bundle/AfSplitter.py
---- revelation.orig/src/bundle/AfSplitter.py 2018-09-01 12:38:17.702662965 +0200
-+++ revelation/src/bundle/AfSplitter.py 2018-09-01 12:30:00.584871451 +0200
-@@ -42,14 +42,8 @@
-
- # will need changed to use Crypto.Random (now in python-crypt git)
- # see: http://lists.dlitz.net/pipermail/pycrypto/2008q3/000020.html
--from Crypto.Util.randpool import RandomPool
--from Crypto.Cipher import XOR
--
--def _xor(a, b):
-- """Internal function to performs XOR on two strings a and b"""
--
-- xor = XOR.new(a)
-- return xor.encrypt(b)
-+from Crypto.Random import get_random_bytes
-+from Crypto.Util.strxor import strxor
-
- def _diffuse(block, size, digest):
- """Internal function to diffuse information inside a buffer"""
-@@ -81,26 +75,19 @@
-
- blockSize = len(data)
-
-- rand = RandomPool()
--
- bufblock = "\x00" * blockSize
-
- ret = ""
- for i in range(0, stripes-1):
-
- # Get some random data
-- rand.randomize()
-- rand.stir()
-- r = rand.get_bytes(blockSize)
-- if rand.entropy < 0:
-- print "Warning: RandomPool entropy dropped below 0"
-+ r = get_random_bytes(blockSize)
-
- ret += r
-- bufblock = _xor(r, bufblock)
-+ bufblock = strxor(r, bufblock)
- bufblock = _diffuse(bufblock, blockSize, digesttype)
-- rand.add_event(bufblock)
-
-- ret += _xor(bufblock, data)
-+ ret += strxor(bufblock, data)
- return ret
-
- def AFMerge(data, stripes, digesttype='sha1'):
-@@ -113,7 +100,7 @@
-
- bufblock = "\x00" * blockSize
- for i in range(0, stripes - 1):
-- bufblock = _xor(data[i*blockSize:(i+1)*blockSize], bufblock)
-+ bufblock = strxor(data[i*blockSize:(i+1)*blockSize], bufblock)
- bufblock = _diffuse(bufblock, blockSize, digesttype)
-
-- return _xor(data[(stripes-1)*blockSize:], bufblock)
-+ return strxor(data[(stripes-1)*blockSize:], bufblock)
-diff -Naur revelation.orig/src/bundle/luks.py revelation/src/bundle/luks.py
---- revelation.orig/src/bundle/luks.py 2018-09-01 12:38:17.702662965 +0200
-+++ revelation/src/bundle/luks.py 2018-09-01 12:47:42.047084845 +0200
-@@ -65,7 +65,7 @@
-
- # will need changed to use Crypto.Random (now in python-crypt git)
- # see: http://lists.dlitz.net/pipermail/pycrypto/2008q3/000020.html
--from Crypto.Util.randpool import RandomPool
-+from Crypto.Random import get_random_bytes
- from Crypto.Cipher import *
- import PBKDFv2, AfSplitter
-
-@@ -178,13 +178,11 @@
- self.keyBytes = masterSize
- self.hashSpec = hashSpec
-
-- rand = RandomPool(self.SALT_SIZE + 16 + masterSize)
--
- # Generate the salt
-- self.mkDigestSalt = rand.get_bytes(self.SALT_SIZE)
-+ self.mkDigestSalt = get_random_bytes(self.SALT_SIZE)
-
- # Generate a random master key
-- self.masterKey = rand.get_bytes(self.keyBytes)
-+ self.masterKey = get_random_bytes(self.keyBytes)
- self.ivGen.set_key(self.masterKey)
-
- # generate the master key digest
-@@ -210,7 +208,7 @@
- self.payloadOffset = currentSector
-
- # Generate a UUID for this file
-- self._uuidgen(rand)
-+ self._uuidgen()
-
- # Create a new file, and save the header into it
- self.file = file
-@@ -263,8 +261,7 @@
- key.passwordIterations = iterations
-
- # Generate a random salt for this key
-- rand = RandomPool(self.SALT_SIZE)
-- key.passwordSalt = rand.get_bytes(self.SALT_SIZE)
-+ key.passwordSalt = get_random_bytes(self.SALT_SIZE)
-
- # Hash the key using PBKDFv2
- pbkdf = PBKDFv2.PBKDFv2()
-@@ -594,13 +591,13 @@
- self.cipherName = cipherName
- self.cipherMode = cipherMode
-
-- def _uuidgen(self, rand):
-+ def _uuidgen(self):
- """Internal function to generate a UUID"""
-
- # I copied this code (and slightly modified it) from a module written
- # by Denys Duchier http://ofxsuite.berlios.de/uuid.py (which is under the GPL)
-
-- buf = rand.get_bytes(16)
-+ buf = get_random_bytes(16)
- low,mid,hi_and_version,seq,node = struct.unpack(">IHHH6s",buf)
- seq = (seq & 0x3FFF) | 0x8000
- hi_and_version = (hi_and_version & 0x0FFF) | 0x4000
-diff -Naur revelation.orig/src/bundle/PBKDFv2.py revelation/src/bundle/PBKDFv2.py
---- revelation.orig/src/bundle/PBKDFv2.py 2018-09-01 12:38:17.702662965 +0200
-+++ revelation/src/bundle/PBKDFv2.py 2018-09-01 12:35:22.345594877 +0200
-@@ -32,7 +32,7 @@
- """
-
- import struct, string, math, hashlib, hmac # RFC2104
--from Crypto.Cipher import XOR
-+from Crypto.Util.strxor import strxor
-
- ################ PBKDFv2
- class PBKDFv2:
-@@ -145,5 +145,4 @@
- if len(a) != len(b):
- raise ValueError("ERROR: Strings are of different size! %s %s" % (len(a), len(b)))
-
-- xor = XOR.new(a)
-- return xor.encrypt(b)
-+ return strxor(a, b)
diff --git a/gnome-python.patch b/gnome-python.patch
deleted file mode 100644
index 82a02fb259bd..000000000000
--- a/gnome-python.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From dffb8b7722865a82c3a5d7ce9615b6da2313d583 Mon Sep 17 00:00:00 2001
-Message-Id: <dffb8b7722865a82c3a5d7ce9615b6da2313d583.1486417682.git.tommyhebb@gmail.com>
-From: Thomas Hebb <tommyhebb@gmail.com>
-Date: Mon, 6 Feb 2017 21:44:06 +0000
-Subject: [PATCH] Remove deprecated gnome-python dependency from configure.ac
-
-The code has not depended on the module for many years (the module was
-removed in 125cf9dc28f95617fc3b37bc29a714f708b7d2ef); however, the
-configure script was never updated to match.
----
- configure.ac | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index bdfae2a..5b6ad72 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -19,7 +19,6 @@ RVL_FDO_MIME()
- RVL_PYTHON_MODULE(Crypto, yes)
- RVL_PYTHON_MODULE(gconf, yes)
- RVL_PYTHON_MODULE(gtk, yes)
--RVL_PYTHON_MODULE(gnome, yes)
- RVL_PYTHON_MODULE(gio, yes)
- RVL_PYTHON_MODULE(gobject, yes)
- RVL_PYTHON_MODULE(pango, yes)
---
-2.11.1
-
diff --git a/revelation.install b/revelation.install
deleted file mode 100644
index 39e53e3de8bc..000000000000
--- a/revelation.install
+++ /dev/null
@@ -1,26 +0,0 @@
-pkgname=revelation
-
-post_install() {
- gconfpkg --install ${pkgname}
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
- update-mime-database usr/share/mime > /dev/null
-}
-
-pre_upgrade() {
- pre_remove $1
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- gconfpkg --uninstall ${pkgname}
-}
-
-post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
- update-mime-database usr/share/mime > /dev/null
-}