summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-01-07 11:27:14 -0700
committerMark Wagie2022-01-07 11:27:14 -0700
commit09da6bac60893b6bd49cbc5f01b4887095ded000 (patch)
tree4273705d23c7468934f10cfe527e3465c5883d8a
parent80ab16bed22c6dc5fcf714c1377337e2de398ab6 (diff)
downloadaur-09da6bac60893b6bd49cbc5f01b4887095ded000.tar.gz
minor PKGBUILD improvements
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc873c01ab32..cd7fd5449401 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-liblarch-git
pkgdesc = Python library to easily handle data structure, with a GTK binding
- pkgver = 3.1.0.r0.gb0840da
+ pkgver = 3.1.0.r9.gab053ac
pkgrel = 1
url = https://wiki.gnome.org/Projects/liblarch
arch = any
@@ -17,4 +17,3 @@ pkgbase = python-liblarch-git
sha256sums = SKIP
pkgname = python-liblarch-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f864cbb354ff..5197aa5aaad4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-liblarch-git
_name=liblarch
-pkgver=3.1.0.r0.gb0840da
+pkgver=3.1.0.r9.gab053ac
pkgrel=1
pkgdesc="Python library to easily handle data structure, with a GTK binding"
arch=('any')
@@ -17,22 +17,21 @@ source=("git+https://github.com/getting-things-gnome/liblarch.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_name"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$_name"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$_name"
- python setup.py build
+ cd "$srcdir/$_name"
+ python setup.py build
}
check() {
- cd "$srcdir/$_name"
- python run-tests
+ cd "$srcdir/$_name"
+ python run-tests
}
package() {
- cd "$srcdir/$_name"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$srcdir/$_name"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}