summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfzerorubigd2015-06-09 09:57:16 +0430
committerfzerorubigd2015-06-09 09:57:16 +0430
commit09ea713018d6d8ff43413612b1f5ae7ea1e5adc3 (patch)
treef2d0647c7ab466359d96340f29449dcefdbe18d7
downloadaur-09ea713018d6d8ff43413612b1f5ae7ea1e5adc3.tar.gz
migrate from aur3
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore11
-rw-r--r--LAV_Source_fix.patch13
-rw-r--r--PKGBUILD55
-rw-r--r--cast-bug.patch12
-rw-r--r--glibfix.patch11
-rw-r--r--lastfm-scrobbler3
-rw-r--r--lastfm-scrobbler.desktop10
8 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8fdd79e6eda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = lastfm
+ pkgdesc = The official Last.fm desktop application suite
+ pkgver = 2.1.30
+ pkgrel = 8
+ url = http://www.last.fm/
+ arch = any
+ license = GPL3
+ depends = qt4>4.8
+ depends = ruby
+ depends = liblastfm
+ depends = pkg-config
+ depends = fftw
+ depends = taglib
+ depends = libsamplerate
+ depends = libmad
+ depends = libgpod
+ depends = sqlite
+ depends = phonon
+ depends = phonon-qt4-vlc
+ depends = ffmpeg
+ depends = qtwebkit
+ provides = lastfm
+ conflicts = lastfm-git
+ conflicts = lastfm-mpd-cli
+ conflicts = lastfm-msk
+ conflicts = lastfm-msk-light
+ source = Last.fm-2.1.30.tar.bz2::http://www.last.fm/download/linux
+ source = glibfix.patch
+ source = lastfm-scrobbler
+ source = LAV_Source_fix.patch
+ source = lastfm-scrobbler.desktop
+ source = cast-bug.patch
+ md5sums = 5f13a2f114143a861c6f2572cb152d24
+ md5sums = 2d77a2d19dd5569dc5213ac99b813e52
+ md5sums = a5d3b0b4026d4694a580b099c5f82932
+ md5sums = 3ac4b2bcf2c7121cdc71cbc13bb6e2af
+ md5sums = fa62e46c1085e8893545e81e063a6a61
+ md5sums = 1571a79e34558688f25e17f069b070c2
+
+pkgname = lastfm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0045cadbfc4a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*.xz
+*.zip
+*.deb
+*.tar.gz
+*.tar.gz.asc
+*.tgz
+*.bz2
+/pkg
+/src
+*.gz
+rc
diff --git a/LAV_Source_fix.patch b/LAV_Source_fix.patch
new file mode 100644
index 000000000000..3657e1bf046e
--- /dev/null
+++ b/LAV_Source_fix.patch
@@ -0,0 +1,13 @@
+--- lastfm-desktop-2.1.30/app/client/Fingerprinter/LAV_Source.cpp
++++ lastfm-desktop-2.1.30/app/client/Fingerprinter/LAV_Source.cpp
+@@ -83,8 +83,8 @@
+ int duration;
+ int bitrate;
+ bool eof;
+- uint8_t outBuffer[AVCODEC_MAX_AUDIO_FRAME_SIZE*4];
+- uint8_t overflow[AVCODEC_MAX_AUDIO_FRAME_SIZE*4];
++ uint8_t outBuffer[192000*4];
++ uint8_t overflow[192000*4];
+ size_t overflowSize;
+ };
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e1149891d0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: FzerorubigD <Fzerorubigd {AT} GMail {DOT} com>
+
+pkgname=lastfm
+pkgver=2.1.30
+pkgrel=8
+pkgdesc="The official Last.fm desktop application suite"
+arch=('any')
+url="http://www.last.fm/"
+license=('GPL3')
+depends=('qt4>4.8' 'ruby' 'liblastfm' 'pkg-config' 'fftw' 'taglib' 'libsamplerate' 'libmad' 'libgpod' 'sqlite' 'phonon' 'phonon-qt4-vlc' 'ffmpeg' 'qtwebkit')
+makedepends=()
+source=(Last.fm-$pkgver.tar.bz2::http://www.last.fm/download/linux
+ glibfix.patch
+ lastfm-scrobbler
+ LAV_Source_fix.patch
+ lastfm-scrobbler.desktop
+ cast-bug.patch)
+conflicts=(lastfm-git
+ lastfm-mpd-cli
+ lastfm-msk
+ lastfm-msk-light)
+
+provides=(lastfm)
+
+#install=$pkgname.install
+
+build() {
+ cd $srcdir/lastfm-desktop-$pkgver
+ patch -Np1 -i ../glibfix.patch
+ patch -Np1 -i ../LAV_Source_fix.patch
+ patch -Np1 -i ../cast-bug.patch
+ qmake-qt4 -r
+ make
+
+}
+
+package() {
+ cd "$srcdir/lastfm-desktop-$pkgver"
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/opt/last.fm/css
+ mkdir -p $pkgdir/usr/share/applications
+ mkdir -p $pkgdir/usr/share/pixmaps
+ cp -R _bin $pkgdir/opt/last.fm/bin
+ cp "app/client/Last.fm Scrobbler.css" $pkgdir/opt/last.fm/css
+ install -m755 $srcdir/lastfm-scrobbler $pkgdir/usr/bin/lastfm-scrobbler
+ install -D -m644 "${srcdir}/lastfm-scrobbler.desktop" "${pkgdir}/usr/share/applications/"
+ install -D -m644 "${srcdir}/lastfm-desktop-$pkgver/app/client/audioscrobbler.ico" "${pkgdir}/usr/share/pixmaps/audioscrobbler.ico"
+}
+
+md5sums=('5f13a2f114143a861c6f2572cb152d24'
+ '2d77a2d19dd5569dc5213ac99b813e52'
+ 'a5d3b0b4026d4694a580b099c5f82932'
+ '3ac4b2bcf2c7121cdc71cbc13bb6e2af'
+ 'fa62e46c1085e8893545e81e063a6a61'
+ '1571a79e34558688f25e17f069b070c2')
diff --git a/cast-bug.patch b/cast-bug.patch
new file mode 100644
index 000000000000..bd7a6895db1e
--- /dev/null
+++ b/cast-bug.patch
@@ -0,0 +1,12 @@
+--- lastfm-desktop-2.1.30/app/client/Services/RadioService/RadioService.cpp
++++ lastfm-desktop-2.1.30/app/client/Services/RadioService/RadioService.cpp
+@@ -309,7 +309,7 @@
+ void
+ RadioService::onPhononStateChanged( Phonon::State newstate, Phonon::State oldstate )
+ {
+- qDebug() << oldstate << " -> " << newstate;
++ qDebug() << (int)oldstate << " -> " << (int)newstate;
+ if (m_mediaObject == 0) {
+ qDebug() << "m_mediaObject is null!";
+ return;
+
diff --git a/glibfix.patch b/glibfix.patch
new file mode 100644
index 000000000000..d8e0e612af2b
--- /dev/null
+++ b/glibfix.patch
@@ -0,0 +1,11 @@
+--- lastfm-desktop-2.1.30/app/client/MediaDevices/IpodDevice_linux.cpp
++++ lastfm-desktop-2.1.30/app/client/MediaDevices/IpodDevice_linux.cpp
+@@ -34,7 +34,7 @@
+ extern "C"
+ {
+ #include <gpod/itdb.h>
+- #include <glib/glist.h>
++ #include <glib.h>
+ }
+
+ IpodTracksFetcher::IpodTracksFetcher( Itdb_iTunesDB *itdb, QSqlDatabase scrobblesdb,
diff --git a/lastfm-scrobbler b/lastfm-scrobbler
new file mode 100644
index 000000000000..01de669b635a
--- /dev/null
+++ b/lastfm-scrobbler
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/last.fm
+LD_LIBRARY_PATH=bin bin/Last.fm\ Scrobbler -stylesheet css/Last.fm\ Scrobbler.css
diff --git a/lastfm-scrobbler.desktop b/lastfm-scrobbler.desktop
new file mode 100644
index 000000000000..f5ce65130d36
--- /dev/null
+++ b/lastfm-scrobbler.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=2.1.30
+Type=Application
+Name=Last.fm Scrobbler
+Comment=Official Last.fm Scrobbler
+Exec=lastfm-scrobbler
+Icon=/usr/share/pixmaps/audioscrobbler.ico
+Categories=Qt;AudioVideo;
+Terminal=false
+StartupNotify=true