summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2017-10-02 09:59:27 +0800
committerpingplug2017-10-02 09:59:27 +0800
commit09eac0479bc012f15de15fb2bb28e0d031b72e4f (patch)
tree92aa90603aa8b72c9cfe6b4c77cae79a96ea6d11
parentaa2ae53f7dccfe54eaf23c093db945b91e82ce19 (diff)
downloadaur-09eac0479bc012f15de15fb2bb28e0d031b72e4f.tar.gz
fix mingw-w64-readline build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--pdcurses.diff43
3 files changed, 57 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aae9933944d3..f1608518288d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 17 07:03:08 UTC 2017
+# Mon Oct 2 01:58:36 UTC 2017
pkgbase = mingw-w64-pdcurses-win32a
pkgdesc = Curses library on the Win32 API for MinGW-w64
pkgver = 4.0.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.projectpluto.com/win32a.htm
arch = any
license = public domain
@@ -16,7 +16,9 @@ pkgbase = mingw-w64-pdcurses-win32a
options = !buildflags
options = !strip
source = git+https://github.com/Bill-Gray/PDCurses.git#commit=10ee49e4fb96a808aed0882374dcc22b668db722
- md5sums = SKIP
+ source = pdcurses.diff
+ sha512sums = SKIP
+ sha512sums = 6d360684f29211a3beb3da5285cb468f66c2f67ade8678be01b822d1ccb2dcf84ff9f76a6e0550da4e76e5952f6c0eb42e22fe31e4c6846b5a0d450e75bd81ef
pkgname = mingw-w64-pdcurses-win32a
diff --git a/PKGBUILD b/PKGBUILD
index d5acc9776471..02ada7520825 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Filip Brcic <brcha@gna.org>
pkgname=mingw-w64-pdcurses-win32a
pkgver=4.0.2
-pkgrel=1
+pkgrel=2
_commit=10ee49e4fb96a808aed0882374dcc22b668db722
pkgdesc="Curses library on the Win32 API for MinGW-w64"
arch=(any)
@@ -17,13 +17,18 @@ conflicts=('mingw-w64-pdcurses')
license=("public domain")
url="http://www.projectpluto.com/win32a.htm"
source=(#"http://www.projectpluto.com/win32a.zip"
- "git+https://github.com/Bill-Gray/PDCurses.git#commit=$_commit")
-md5sums=('SKIP')
+ "git+https://github.com/Bill-Gray/PDCurses.git#commit=$_commit"
+ "pdcurses.diff")
+sha512sums=('SKIP'
+ '6d360684f29211a3beb3da5285cb468f66c2f67ade8678be01b822d1ccb2dcf84ff9f76a6e0550da4e76e5952f6c0eb42e22fe31e4c6846b5a0d450e75bd81ef')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/PDCurses"
+ cd "${srcdir}"
+
+ # export functions in terms.h
+ patch -Np0 -i pdcurses.diff
}
build() {
diff --git a/pdcurses.diff b/pdcurses.diff
new file mode 100644
index 000000000000..662d22308bfb
--- /dev/null
+++ b/pdcurses.diff
@@ -0,0 +1,43 @@
+diff -ruN PDCurses-patched/term.h PDCurses/term.h
+--- PDCurses-patched/term.h 2017-10-02 09:48:51.000000000 +0800
++++ PDCurses/term.h 2017-10-02 09:49:28.290552879 +0800
+@@ -23,23 +23,23 @@
+ /* PDCEX is defined in curses.h */
+ PDCEX TERMINAL *cur_term;
+
+-int del_curterm(TERMINAL *);
+-int putp(const char *);
+-int restartterm(const char *, int, int *);
+-TERMINAL *set_curterm(TERMINAL *);
+-int setterm(const char *);
+-int setupterm(const char *, int, int *);
+-int tgetent(char *, const char *);
+-int tgetflag(const char *);
+-int tgetnum(const char *);
+-char *tgetstr(const char *, char **);
+-char *tgoto(const char *, int, int);
+-int tigetflag(const char *);
+-int tigetnum(const char *);
+-char *tigetstr(const char *);
+-char *tparm(const char *, long, long, long, long, long,
++PDCEX int del_curterm(TERMINAL *);
++PDCEX int putp(const char *);
++PDCEX int restartterm(const char *, int, int *);
++PDCEX TERMINAL *set_curterm(TERMINAL *);
++PDCEX int setterm(const char *);
++PDCEX int setupterm(const char *, int, int *);
++PDCEX int tgetent(char *, const char *);
++PDCEX int tgetflag(const char *);
++PDCEX int tgetnum(const char *);
++PDCEX char *tgetstr(const char *, char **);
++PDCEX char *tgoto(const char *, int, int);
++PDCEX int tigetflag(const char *);
++PDCEX int tigetnum(const char *);
++PDCEX char *tigetstr(const char *);
++PDCEX char *tparm(const char *, long, long, long, long, long,
+ long, long, long, long);
+-int tputs(const char *, int, int (*)(int));
++PDCEX int tputs(const char *, int, int (*)(int));
+
+ #if defined(__cplusplus) || defined(__cplusplus__) || defined(__CPLUSPLUS)
+ }