summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2020-09-29 16:03:22 +0700
committerKonstantin Shalygin2020-09-29 16:03:22 +0700
commit0a23931b31ee580f27e8fceb2d88518a8133a8e6 (patch)
tree9862a546319d437c263c87b214e96e3737157a1f
downloadaur-0a23931b31ee580f27e8fceb2d88518a8133a8e6.tar.gz
Initial release of python-resize-image
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD34
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71fe2b6bb414
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-resize-image
+ pkgdesc = Search for image using Google Custom Search API and resize & crop the image afterwords
+ pkgver = 1.1.19
+ pkgrel = 1
+ url = https://github.com/arrrlo/Google-Images-Search
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
+ source = https://pypi.io/packages/source/p/python-resize-image/python-resize-image-1.1.19.tar.gz
+ sha256sums = 2aea25e9811fd44d4cb8fef82059ace114f6cc72bbef059f69b0b7f79f55e03e
+
+pkgname = python-resize-image
+ depends = python-requests
+ depends = python-pillow
+
+pkgname = python2-resize-image
+ depends = python2-requests
+ depends = python2-pillow
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7c6927b4669a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/*
+src/*
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7906f54f083
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Konstantin Shalygin <k0ste@k0ste.ru>
+# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
+
+pkgbase='python-resize-image'
+pkgname=('python-resize-image' 'python2-resize-image')
+pkgver='1.1.19'
+pkgrel='1'
+pkgdesc="Search for image using Google Custom Search API and resize & crop the image afterwords"
+arch=("any")
+url="https://github.com/arrrlo/Google-Images-Search"
+makedepends=('python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+license=('MIT')
+source=("https://pypi.io/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('2aea25e9811fd44d4cb8fef82059ace114f6cc72bbef059f69b0b7f79f55e03e')
+
+build() {
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py build
+}
+
+package_python-resize-image() {
+ depends=('python-requests' 'python-pillow')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py install -O1 --root="${pkgdir}"
+}
+
+package_python2-resize-image() {
+ depends=('python2-requests' 'python2-pillow')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python2 setup.py install -O1 --root="${pkgdir}"
+}