summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasato Hashimoto2015-06-20 20:21:05 +0900
committerMasato Hashimoto2015-06-20 20:21:05 +0900
commit0a2bac0bfc4829e397ddddd2bcf7eb35ca28ad11 (patch)
tree0d0304ca587f640513e818d750e4ec38ef247508
downloadaur-0a2bac0bfc4829e397ddddd2bcf7eb35ca28ad11.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--otf.install15
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18efdf3d4b95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-takao
+ pkgdesc = Japanese outline fonts based on IPA Fonts (otf-ipafont)
+ pkgver = 15.03
+ pkgrel = 1
+ url = https://launchpad.net/takao-fonts
+ install = otf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://launchpad.net/takao-fonts/trunk/15.03/+download/TakaoFonts_00303.01.tar.xz
+ md5sums = 8cd3fe724faa5034a9369e98cf108d2d
+
+pkgname = otf-takao
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86c3b4b583ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ponsfoot <cabezon dot hashimoto at gmail dot com>
+
+pkgname=otf-takao
+pkgver=15.03
+pkgrel=1
+_filever=00303.01
+pkgdesc="Japanese outline fonts based on IPA Fonts (otf-ipafont)"
+arch=('any')
+url="https://launchpad.net/takao-fonts"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=otf.install
+source=(http://launchpad.net/takao-fonts/trunk/${pkgver}/+download/TakaoFonts_${_filever}.tar.xz)
+md5sums=('8cd3fe724faa5034a9369e98cf108d2d')
+
+package() {
+ cd "${srcdir}/TakaoFonts_${_filever}"
+
+ install -d "${pkgdir}/usr/share/fonts/OTF"
+
+ install -m644 *.ttf "${pkgdir}/usr/share/fonts/OTF/"
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 IPA_Font_License_Agreement_v1.0.txt \
+ README \
+ README.ja \
+ "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..2158e59eac20
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}