summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2023-02-03 14:28:20 +1000
committerBrenton Horne2023-02-03 14:28:20 +1000
commit0a3cf79633f6ca70e80b31b9bd0825d7d2286b6e (patch)
tree4c8024cbeb6af8e7ad047a71f5963ed11b9649a4
downloadaur-0a3cf79633f6ca70e80b31b9bd0825d7d2286b6e.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD48
-rwxr-xr-xopenra-wts-git.install21
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..684e7b3454fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = openra-wts-git
+ pkgdesc = OpenRA built from latest git commit and with the experimental Tiberian Sun mod included.
+ pkgver = 29131.git.f5aa2f1
+ pkgrel = 1
+ url = https://www.openra.net
+ install = openra-wts-git.install
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = unzip
+ makedepends = mono-msbuild
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ conflicts = openra
+ conflicts = openra-bleed
+ conflicts = openra-git
+ options = !strip
+ source = git+https://github.com/OpenRA/OpenRA.git
+ source = https://raw.githubusercontent.com/wiki/OpenRA/OpenRA/Changelog.md
+ sha256sums = SKIP
+ sha256sums = 5d07623dc97c88b07435f54857093ca41073d96b93a4c8b5bf8fd0768835a8ff
+
+pkgname = openra-wts-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ea656c99ae09
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+pkg
+src
+OpenRA
+*.xz
+*.gz
+Changelog.md
+*.patch
+.*.swp
+octave-workspace
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a409a0561316
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Brenton Horne <brentonhorne77@gmail.com>
+
+pkgname=openra-wts-git
+pkgver=29131.git.f5aa2f1
+pkgrel=1
+pkgdesc="OpenRA built from latest git commit and with the experimental Tiberian Sun mod included."
+arch=('x86_64')
+url="https://www.openra.net"
+license=('GPL3')
+install=${pkgname}.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('git' 'unzip' 'mono-msbuild')
+conflicts=('openra' 'openra-bleed' 'openra-git')
+options=(!strip)
+source=("git+https://github.com/OpenRA/OpenRA.git"
+"https://raw.githubusercontent.com/wiki/OpenRA/OpenRA/Changelog.md")
+sha256sums=('SKIP'
+ '5d07623dc97c88b07435f54857093ca41073d96b93a4c8b5bf8fd0768835a8ff')
+
+pkgver() {
+ cd $srcdir/OpenRA
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ version="${no}.git.${hash}"
+ make version VERSION="${version}"
+}
+
+build() {
+ cd $srcdir/OpenRA
+ make all RUNTIME=mono DEBUG=false TARGETPLATFORM=unix-generic
+}
+
+package() {
+ cd $srcdir/OpenRA
+ mkdir -p $pkgdir/usr/lib/openra
+ make prefix=/usr DESTDIR="$pkgdir" install DEBUG=false RUNTIME=mono
+ make prefix=/usr DESTDIR="$pkgdir" install-linux-shortcuts DEBUG=false
+ make prefix=/usr DESTDIR="$pkgdir" install-linux-appdata DEBUG=false
+ cp -r mods/ts $pkgdir/usr/lib/openra/mods
+ cp $pkgdir/usr/bin/openra-ra $pkgdir/usr/bin/openra-ts
+ cp $pkgdir/usr/share/applications/openra-ra.desktop $pkgdir/usr/share/applications/openra-ts.desktop
+ sed -i -e "s|-ra|-ts|g" \
+ -e "s|=ra|=ts|g" \
+ -e "s|Red Alert|Tiberian Sun|g" $pkgdir/usr/bin/openra-ts
+ sed -i -e "s|-ra|-ts|g" \
+ -e "s|Red Alert|Tiberian Sun|g" $pkgdir/usr/share/applications/openra-ts.desktop
+}
diff --git a/openra-wts-git.install b/openra-wts-git.install
new file mode 100755
index 000000000000..247b44074f8e
--- /dev/null
+++ b/openra-wts-git.install
@@ -0,0 +1,21 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ gtk-update-icon-cache -q -t -f usr/share/pixmaps
+}
+
+post_install() {
+ echo "If the game doesn't run, try using the Cg renderer ~/.openra/settings.yaml like so:"
+ echo "Graphics:"
+ echo " Renderer: Cg"
+ echo "Be careful to only use one indenting tab with 8 shift width."
+ echo "Note this includes the Tiberian Sun mod, which is very experimental."
+ echo "Report bugs at https://github.com/OpenRA/OpenRA/issues."
+ post_upgrade
+}
+
+post_remove() {
+ echo "openra downloaded data files to ~/.openra/Content and you might want"
+ echo "to delete those."
+ post_upgrade
+}