summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-15 21:56:33 +0100
committerCarl Smedstad2024-01-15 22:10:46 +0100
commit0a3d661c45bfe8e25f74f31ec1bbab16716318e0 (patch)
treeeaf2b0b399bba7a2a862c75913b974aa7cfec832
parent85f4de062c4c7d520c966010e6457425b0f557e0 (diff)
downloadaur-0a3d661c45bfe8e25f74f31ec1bbab16716318e0.tar.gz
upgpkg: python-xhtml2pdf 0.2.13-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b18e02cbe803..244113849a9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-xhtml2pdf
pkgdesc = A library for converting HTML into PDFs using ReportLab
pkgver = 0.2.13
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xhtml2pdf/xhtml2pdf
arch = any
- license = Apache
+ license = Apache-2.0
checkdepends = python-nose
makedepends = python-build
makedepends = python-installer
@@ -12,8 +12,8 @@ pkgbase = python-xhtml2pdf
makedepends = python-wheel
makedepends = python-sphinx_rtd_theme
makedepends = python-sphinxcontrib-pdfembed
- makedepends = texlive-latexextra
makedepends = texlive-fontsextra
+ makedepends = texlive-latexextra
depends = python
depends = python-arabic-reshaper
depends = python-asn1crypto
diff --git a/PKGBUILD b/PKGBUILD
index 59451c689215..794e40e37375 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
pkgname=python-xhtml2pdf
_name=${pkgname#python-}
pkgver=0.2.13
-pkgrel=1
+pkgrel=2
pkgdesc="A library for converting HTML into PDFs using ReportLab"
arch=(any)
url="https://github.com/xhtml2pdf/xhtml2pdf"
-license=(Apache)
+license=(Apache-2.0)
depends=(
python
python-arabic-reshaper
@@ -29,18 +29,16 @@ makedepends=(
python-installer
python-setuptools
python-wheel
-
+ # Documentation
python-sphinx_rtd_theme
python-sphinxcontrib-pdfembed
- texlive-latexextra
texlive-fontsextra
+ texlive-latexextra
)
-checkdepends=(
- python-nose
-)
+checkdepends=(python-nose)
source=(
- "$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v${pkgver}.tar.gz"
+ "$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
"exclude-packages.patch"
)
sha256sums=(
@@ -53,12 +51,13 @@ _archive="$_name-$pkgver"
prepare() {
cd "$_archive"
- patch --forward --strip=1 --input="${srcdir}/exclude-packages.patch"
+ patch --forward --strip=1 --input="$srcdir/exclude-packages.patch"
}
build() {
cd "$_archive"
+ rm -rf build
python -m build --wheel --no-isolation
export PYTHONPATH=$PWD/docs/source:$PWD
@@ -79,5 +78,5 @@ package() {
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
cp -R docs/build/html "$pkgdir/usr/share/doc/$pkgname"
- install -Dm644 docs/build/man/xhtml2pdf.1 "$pkgdir/usr/share/man/man1/xhtml2pdf.1"
+ install -Dm644 -t "$pkgdir/usr/share/man/man1" docs/build/man/xhtml2pdf.1
}