summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancakes2018-11-20 19:30:31 +0100
committerKevin Azzam2018-11-20 19:30:31 +0100
commit0a5a9a09df8c595a70fe176aee57086cc384d5fd (patch)
tree77141d3a47dce87b8d96e7c396fca15231f68556
parent47c8c100c37a894765cfcf6d5e45e895915e0b43 (diff)
downloadaur-0a5a9a09df8c595a70fe176aee57086cc384d5fd.tar.gz
Update to v2.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 24 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46751a27dc04..3a29c0c86b0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-krakenex
- pkgdesc = Wrapper for krakenex
- pkgver = v3.1.0.r0.g1d06fe5
+ pkgdesc = Exchange API for Kraken.com
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/veox/python3-krakenex
- arch = x86_64
- license = LGPLv3
- makedepends = git
- depends = python>=3.6
- provides = python-krakenex
- source = python-krakenex::git+https://github.com/veox/python3-krakenex.git
- md5sums = SKIP
+ arch = any
+ license = LGPL
+ makedepends = python-setuptools
+ source = https://github.com/veox/python3-krakenex/archive/v2.1.0.tar.gz
+ sha1sums = de79e2b7b49cf370078374b116b389f313f3bc79
pkgname = python-krakenex
+ depends =
diff --git a/PKGBUILD b/PKGBUILD
index 775db9c78421..74ec9bf39c62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,25 @@
# Contributor: vsilv <vsilv@posteo.eu>
-# Maintainer : vsilv <vsilv@posteo.eu>
+# Contributor: pancakes <aur@azz.am>
+
+_ghname=python3-krakenex
pkgname=python-krakenex
-pkgver=v3.1.0.r0.g1d06fe5
+pkgver=2.1.0
pkgrel=1
-pkgdesc="Wrapper for krakenex"
-arch=('x86_64')
+pkgdesc="Exchange API for Kraken.com"
+arch=('any')
url="https://github.com/veox/python3-krakenex"
-license=('LGPLv3')
-depends=('python>=3.6')
-makedepends=('git')
-provides=('python-krakenex')
-source=('python-krakenex::git+https://github.com/veox/python3-krakenex.git')
+license=('LGPL')
+makedepends=('python-setuptools')
+source=("https://github.com/veox/$_ghname/archive/v$pkgver.tar.gz")
+sha1sums=('de79e2b7b49cf370078374b116b389f313f3bc79')
-md5sums=('SKIP')
-_gitname='python-krakenex'
-
-pkgver() {
- cd "$srcdir/$_gitname"
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
-}
-build() {
- cd "${srcdir}/${_gitname}"
- python setup.py build
-}
package() {
- cd "${srcdir}/${_gitname}"
- python setup.py install --prefix=/usr --root=${pkgdir} -O1 --skip-build
+ cd $_ghname-$pkgver
+ cp LICENSE.txt LICENSE
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
+ install -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname
}