summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorghostlovescore2019-10-11 20:25:17 +0200
committerghostlovescore2019-10-11 20:25:17 +0200
commit0a5c1c7e9b324b3c9915b3dc1b00a4d790a6ada6 (patch)
tree24c65da757756bf647bf0060c8d6e34ced573a4a
downloadaur-0a5c1c7e9b324b3c9915b3dc1b00a4d790a6ada6.tar.gz
goenv first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09a8b72603c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = goenv-git
+ pkgdesc = Like pyenv and rbenv, but for Go.
+ pkgver = r1724.0cbe222
+ pkgrel = 1
+ url = https://github.com/syndbg/goenv
+ arch = i686
+ arch = x86_64
+ license = MIT
+ options = !libtool
+ options = docs
+ options = strip
+ source = git://github.com/syndbg/goenv.git
+ md5sums = SKIP
+
+pkgname = goenv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebd4a5256dff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: gls <ghostlovescorebg at gmail dot com>
+
+pkgname=goenv-git
+pkgver=r1724.0cbe222
+pkgrel=1
+pkgdesc="Like pyenv and rbenv, but for Go."
+arch=('i686' 'x86_64')
+url="https://github.com/syndbg/goenv"
+license=('MIT')
+source=("git://github.com/syndbg/goenv.git")
+options=('!libtool' 'docs' 'strip')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%%-git}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname%%-git}"
+
+ for file in $(ls -1 libexec/); do
+ install -D -m755 libexec/${file} "${pkgdir}/usr/lib/goenv/libexec/${file}"
+ done
+
+}