summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2022-03-18 11:30:11 +0200
committerAdrian Perez de Castro2022-03-18 11:30:11 +0200
commit0a826d08a01d42010d12da42bca6b0734442bbc1 (patch)
tree4fac4efa8b191fc832be3d8122a594ec6d731415
parentb3620dbfd09e2a335d4f59a91312dd47eee5013b (diff)
downloadaur-0a826d08a01d42010d12da42bca6b0734442bbc1.tar.gz
Bump to version 5.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 50 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8aa6255b253..f93f0b28c7a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xcursor-simp1e
pkgdesc = An aesthetic cursor theme
- pkgver = 0.0.20211003
+ pkgver = 5.0
pkgrel = 1
url = https://gitlab.com/zoli111/simp1e/
arch = any
@@ -9,7 +9,7 @@ pkgbase = xcursor-simp1e
makedepends = librsvg
makedepends = python-pillow
makedepends = xorg-xcursorgen
- source = xcursor-simp1e::git+https://gitlab.com/zoli111/simp1e/#commit=6a9e969b0239a58fc96af787c4986c273eb6d0eb
+ source = xcursor-simp1e::git+https://gitlab.com/zoli111/simp1e/#commit=599160278e64b8cddf0a6ca4fdc946e8c8b81b94
source = builder_script::git+https://github.com/mxre/cursor
sha512sums = SKIP
sha512sums = SKIP
@@ -22,4 +22,19 @@ pkgname = xcursor-simp1e-breeze-snow
pkgname = xcursor-simp1e-dark
-pkgname = xcursor-simp1e-solarized
+pkgname = xcursor-simp1e-catpuccin
+
+pkgname = xcursor-simp1e-solarized-dark
+
+pkgname = xcursor-simp1e-solarized-light
+ replaces = xcursor-simp1e-solarized
+
+pkgname = xcursor-simp1e-gruvbox-dark
+
+pkgname = xcursor-simp1e-gruvbox-light
+
+pkgname = xcursor-simp1e-nord-dark
+
+pkgname = xcursor-simp1e-nord-light
+
+pkgname = xcursor-simp1e-tokyo-night
diff --git a/PKGBUILD b/PKGBUILD
index f3cf872dd4bf..1e1e3513ec90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgbase=xcursor-simp1e
-pkgname=(xcursor-simp1e{,-breeze{,-snow},-dark,-solarized})
+pkgname=(xcursor-simp1e{,-breeze{,-snow},-dark,-catpuccin,-{solarized,gruvbox,nord}-{dark,light},-tokyo-night})
pkgdesc='An aesthetic cursor theme'
-pkgver=0.0.20211003
+pkgver=5.0
pkgrel=1
url=https://gitlab.com/zoli111/simp1e/
-_commit=6a9e969b0239a58fc96af787c4986c273eb6d0eb
+_commit=599160278e64b8cddf0a6ca4fdc946e8c8b81b94
arch=(any)
makedepends=(git librsvg python-pillow xorg-xcursorgen)
depends=()
@@ -23,7 +23,8 @@ prepare () {
build () {
cd "${pkgname}"
- ./build.sh
+ ./generate_svgs.sh
+ ./build_cursors.sh
}
_package () {
@@ -35,14 +36,36 @@ package_xcursor-simp1e () {
_package Simp1e
}
package_xcursor-simp1e-dark () {
- _package Simp1e-dark
+ _package Simp1e-Dark
}
package_xcursor-simp1e-breeze () {
- _package Simp1e-breeze
+ _package Simp1e-Breeze
}
package_xcursor-simp1e-breeze-snow () {
- _package Simp1e-breeze-snow
+ _package Simp1e-Breeze-Snow
}
-package_xcursor-simp1e-solarized () {
- _package Simp1e-solarized
+package_xcursor-simp1e-solarized-light () {
+ replaces=(xcursor-simp1e-solarized)
+ _package Simp1e-Solarized-Light
+}
+package_xcursor-simp1e-solarized-dark () {
+ _package Simp1e-Solarized-Dark
+}
+package_xcursor-simp1e-gruvbox-light () {
+ _package Simp1e-Gruvbox-Light
+}
+package_xcursor-simp1e-gruvbox-dark () {
+ _package Simp1e-Gruvbox-Dark
+}
+package_xcursor-simp1e-nord-light () {
+ _package Simp1e-Nord-Light
+}
+package_xcursor-simp1e-nord-dark () {
+ _package Simp1e-Nord-Dark
+}
+package_xcursor-simp1e-tokyo-night () {
+ _package Simp1e-Tokyo-Night
+}
+package_xcursor-simp1e-catpuccin () {
+ _package Simp1e-Catpuccin
}