summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Kaspar Rudert (mortzu)2020-07-26 11:36:28 +0200
committerMoritz Kaspar Rudert (mortzu)2020-07-26 11:36:28 +0200
commit0a830c3a19f729a5c8dc5f7e9c816a0cb27c2135 (patch)
tree53a55c44b4a24d68f55df52403c5f0cc61277283
downloadaur-0a830c3a19f729a5c8dc5f7e9c816a0cb27c2135.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba506beaef3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-downwards
+ pkgdesc = Read Wikipedia pages as manpages
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/noqqe/downwards/
+ arch = any
+ license = MIT
+ depends = python-unidecode
+ depends = python-click
+ depends = python-wikipedia
+ depends = python-wikitextparser
+ depends = python-regex
+ depends = python-wcwidth
+ depends = python-mako
+ source = python-downwards-1.3.0.tar.gz::https://github.com/noqqe/downwards/archive/v1.3.0.tar.gz
+ sha512sums = af1af63880a956ea1ae8d8c2e52038f7b2c589f443075bdbc44062d03d56d8dcd36b8082295a25a1a5259178dc30a2e9fd1648d05012a17e439b91109b65d664
+
+pkgname = python-downwards
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b3511a779aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=python-downwards
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Read Wikipedia pages as manpages"
+arch=('any')
+url="https://github.com/noqqe/downwards/"
+license=('MIT')
+depends=('python-unidecode' 'python-click' 'python-wikipedia' 'python-wikitextparser' 'python-regex' 'python-wcwidth' 'python-mako')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/noqqe/downwards/archive/v$pkgver.tar.gz")
+sha512sums=('af1af63880a956ea1ae8d8c2e52038f7b2c589f443075bdbc44062d03d56d8dcd36b8082295a25a1a5259178dc30a2e9fd1648d05012a17e439b91109b65d664')
+
+build() {
+ cd "$srcdir"/downwards-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/downwards-$pkgver
+ python setup.py install --skip-build -O1 --root="$pkgdir"
+}