summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoffrey2020-01-25 19:48:14 +0100
committerJoffrey2020-01-25 19:48:14 +0100
commit0a837b1adae52dbf340ed048ca937cd5ef5af96d (patch)
tree1f85becd0e64dcfeef0ef9f88d651dda010d3f49
downloadaur-0a837b1adae52dbf340ed048ca937cd5ef5af96d.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD18
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e99242a60567
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-captcha
+ pkgdesc = A captcha library that generates audio and image CAPTCHAs.
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/lepture/captcha
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ source = python-captcha-0.3.tar.gz::https://github.com/lepture/captcha/archive/v0.3.tar.gz
+ sha256sums = 4e12430461a122ba2d0b7dc288865ceff41512b810653a4405b80af9e21c6a0d
+
+pkgname = python-captcha
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..abc06d159603
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.gz
+*.xz
+*.zip
+/pkg
+/src
+*.log*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2313681d2876
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Joffrey <j-off@live.fr>
+
+pkgname=python-captcha
+pkgver=0.3
+pkgrel=1
+pkgdesc='A captcha library that generates audio and image CAPTCHAs.'
+arch=('any')
+url='https://github.com/lepture/captcha'
+license=('BSD')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('4e12430461a122ba2d0b7dc288865ceff41512b810653a4405b80af9e21c6a0d')
+
+package() {
+ cd "$srcdir/captcha-$pkgver"
+ install -Dm644 './LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python './setup.py' install --root="$pkgdir" --optimize=1
+}