summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2018-07-27 11:00:54 -0400
committerEli Schwartz2018-07-27 11:00:54 -0400
commit0a88ef880660dfbac1da35f568d562fdded46a67 (patch)
treec46c5d5fd356737320f3bf37fb94ffa421e06320
parentb52f57716652399e295c73d98fa6e8ec4cd789d7 (diff)
downloadaur-0a88ef880660dfbac1da35f568d562fdded46a67.tar.gz
upgpkg: pacman-git 5.1.1.r0.g7e081d2a-1
upstream release update distro makepkg.conf to merge in upstream changes
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--makepkg.conf22
3 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67f127340c29..8093238ee4ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacman-git
- pkgdesc = A library-based package manager with dependency support. git version.
- pkgver = 5.1.0.r0.gbe4c491c
+ pkgdesc = A library-based package manager with dependency support
+ pkgver = 5.1.1.r0.g7e081d2a
pkgrel = 1
url = https://www.archlinux.org/pacman/
arch = i686
@@ -21,7 +21,7 @@ pkgbase = pacman-git
depends = libarchive
depends = pacman-mirrorlist
optdepends = pacman-contrib: various helper utilities
- provides = pacman=5.1.0
+ provides = pacman=5.1.1
conflicts = pacman
options = strip
options = debug
@@ -36,7 +36,7 @@ pkgbase = pacman-git
sha256sums = 0c087d26e80333267391a6e9e34b95a2ffb103cb9391cb53cc5d97ad954af774
sha256sums = c5a3ec55f9d1bc52e5e5b127f76b7b16b79738268691a3e1d842359033e460da
sha256sums = 2d17478fd607c75e396fe10ef2add8bc9fcc12054810fb6f4409dfb70e01989e
- sha256sums = 6066d67d818ee36760bf121c76d5019130f7875b3e5ed179b319b810a3a9685b
+ sha256sums = 2d66473febac0e142eb5b5b2b2c6341687b1afaa89c76ca4e6803499b60636f1
pkgname = pacman-git
diff --git a/PKGBUILD b/PKGBUILD
index 1600a2ba6fb3..bcbb12ab3873 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
# Contributor: Andres Perera <aepd87@gmail.com>
pkgname=pacman-git
-pkgver=5.1.0.r0.gbe4c491c
+pkgver=5.1.1.r0.g7e081d2a
pkgrel=1
-pkgdesc="A library-based package manager with dependency support. git version."
+pkgdesc="A library-based package manager with dependency support"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://www.archlinux.org/pacman/"
license=('GPL')
@@ -30,7 +30,7 @@ sha256sums=('SKIP'
'0c087d26e80333267391a6e9e34b95a2ffb103cb9391cb53cc5d97ad954af774'
'c5a3ec55f9d1bc52e5e5b127f76b7b16b79738268691a3e1d842359033e460da'
'2d17478fd607c75e396fe10ef2add8bc9fcc12054810fb6f4409dfb70e01989e'
- '6066d67d818ee36760bf121c76d5019130f7875b3e5ed179b319b810a3a9685b')
+ '2d66473febac0e142eb5b5b2b2c6341687b1afaa89c76ca4e6803499b60636f1')
pkgver() {
cd pacman
diff --git a/makepkg.conf b/makepkg.conf
index 8fa4fb04d2ed..15c2f9ad978a 100644
--- a/makepkg.conf
+++ b/makepkg.conf
@@ -1,3 +1,4 @@
+#!/hint/bash
#
# /etc/makepkg.conf
#
@@ -8,9 +9,10 @@
#
#-- The download utilities that makepkg should use to acquire sources
# Format: 'protocol::agent'
-DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
- 'http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
- 'https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
+DLAGENTS=('file::/usr/bin/curl -gqC - -o %o %u'
+ 'ftp::/usr/bin/curl -gqfC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
+ 'http::/usr/bin/curl -gqb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'https::/usr/bin/curl -gqb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
'rsync::/usr/bin/rsync --no-motd -z %u %o'
'scp::/usr/bin/scp -C %u %o')
@@ -34,8 +36,6 @@ CARCH="@CARCH@"
CHOST="@CHOST@"
#-- Compiler and Linker Flags
-# -march (or -mcpu) builds exclusively for an architecture
-# -mtune optimizes for an architecture, but builds for whole processor family
CPPFLAGS="-D_FORTIFY_SOURCE=2"
CFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
CXXFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
@@ -50,7 +50,7 @@ DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
# BUILD ENVIRONMENT
#########################################################################
#
-# Defaults: BUILDENV=(!distcc color !ccache check !sign)
+# Defaults: BUILDENV=(!distcc !color !ccache check !sign)
# A negated environment option will do the opposite of the comments below.
#
#-- distcc: Use the Distributed C/C++/ObjC compiler
@@ -73,7 +73,7 @@ BUILDENV=(!distcc color !ccache check !sign)
# These are default values for the options=() settings
#########################################################################
#
-# Default: OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
+# Default: OPTIONS=(!strip docs libtool staticlibs emptydirs !zipman !purge !debug)
# A negated option will do the opposite of the comments below.
#
#-- strip: Strip symbols from binaries/libraries
@@ -83,11 +83,9 @@ BUILDENV=(!distcc color !ccache check !sign)
#-- emptydirs: Leave empty directories in packages
#-- zipman: Compress manual (man and info) pages in MAN_DIRS with gzip
#-- purge: Remove files specified by PURGE_TARGETS
-#-- upx: Compress binary executable files using UPX
-#-- optipng: Optimize PNG images with optipng
#-- debug: Add debugging flags as specified in DEBUG_* variables
#
-OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
+OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !debug)
#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
INTEGRITY_CHECK=(md5)
@@ -103,6 +101,8 @@ MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
#-- Files to be removed from all packages (if purge is specified)
PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
+#-- Directory to store source code in for debug packages
+DBGSRCDIR="/usr/src/debug"
#########################################################################
# PACKAGE OUTPUT
@@ -143,5 +143,3 @@ COMPRESSZ=(compress -c -f)
#
PKGEXT='.pkg.tar.xz'
SRCEXT='.src.tar.gz'
-
-# vim: set ft=sh ts=2 sw=2 et: