summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2023-07-17 10:49:59 -0400
committerFantix King2023-11-05 18:10:29 -0500
commit0a985cd8366f9db19faac5411882a430f97c1b0f (patch)
tree05ec7d2adc3a0115b5d21c50ea0066d585f09a87
parent3dfbbdfbb67686f9ff5042fb6c1e79b421c49934 (diff)
downloadaur-0a985cd8366f9db19faac5411882a430f97c1b0f.tar.gz
0.19-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2aa8dbd544b..88f290af4ac4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-immutables
pkgdesc = A high-performance immutable mapping type for Python
- pkgver = 0.15
+ pkgver = 0.19
pkgrel = 1
url = https://github.com/MagicStack/immutables
arch = x86_64
license = custom
- checkdepends = flake8
- checkdepends = python-pycodestyle
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/i/immutables/immutables-0.15.tar.gz
- md5sums = 64628c8d813a4b3e954ef2af531eddc6
+ source = https://files.pythonhosted.org/packages/source/i/immutables/immutables-0.19.tar.gz
+ md5sums = 08810bf330ba17d001166ece05bbb230
pkgname = python-immutables
-
diff --git a/PKGBUILD b/PKGBUILD
index 2c38e6c6a97a..f220515861a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
+# Maintainer: Fantix King <fantix.king@gmail.com>
# Maintainer: Yuuta Liang <yuuta@yuuta.moe>
pkgname=python-immutables
-pkgver=0.15
+pkgver=0.19
pkgrel=1
epoch=
pkgdesc="A high-performance immutable mapping type for Python"
@@ -9,8 +10,8 @@ url="https://github.com/MagicStack/immutables"
license=('custom')
groups=()
depends=('python')
-makedepends=('python-setuptools')
-checkdepends=('flake8' 'python-pycodestyle')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
+checkdepends=()
optdepends=()
provides=()
conflicts=()
@@ -22,7 +23,7 @@ changelog=
_name=${pkgname#python-}
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
noextract=()
-md5sums=('64628c8d813a4b3e954ef2af531eddc6')
+md5sums=('08810bf330ba17d001166ece05bbb230')
validpgpkeys=()
prepare() {
@@ -31,17 +32,17 @@ prepare() {
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd "$_name-$pkgver"
- python -m unittest -v
+ PYTHONPATH=$(ls -d build/lib*) IMMU_SKIP_MYPY_TESTS=1 python tests/__init__.py -v
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
mkdir -p $pkgdir/usr/share/licenses/${pkgname}/
install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/
}