summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-08-17 03:01:30 +0200
committerChristopher Arndt2019-08-17 03:01:30 +0200
commit0adf60ae5e882570b9bc7b0f4020ca9186c02a60 (patch)
treef3357992afc424f8c48f23d450ed581939913d65
parentfe9aff6baed52059f55eb40a8513519d0162c0f7 (diff)
downloadaur-0adf60ae5e882570b9bc7b0f4020ca9186c02a60.tar.gz
Remove Qt4 support
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aad7f414cf1d..b7546cad83c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jalv-git
pkgdesc = A simple but fully featured LV2 host for Jack
- pkgver = 1.6.1.r443.3dc259e
+ pkgver = 1.6.2.r450.57b35f6
pkgrel = 1
url = http://drobilla.net/software/jalv/
arch = i686
@@ -12,14 +12,12 @@ pkgbase = jalv-git
makedepends = gtkmm
makedepends = jack
makedepends = python
- makedepends = qt4
makedepends = qt5-base
depends = lilv
depends = suil
optdepends = gtk2: Gtk+ 2.x frontend
optdepends = gtk3: Gtk+ 3.x frontend
optdepends = gtkmm: Gtk++ 2.x frontend
- optdepends = qt4: Qt 4.x frontend
optdepends = qt5-base: Qt 5.x frontend
provides = jalv
conflicts = jalv
diff --git a/PKGBUILD b/PKGBUILD
index ac47727186c6..adfdad945719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,19 @@
_pkgname=jalv
pkgname="${_pkgname}-git"
-pkgver=1.6.1.r443.3dc259e
+pkgver=1.6.2.r450.57b35f6
pkgrel=1
pkgdesc="A simple but fully featured LV2 host for Jack"
arch=('i686' 'x86_64')
url="http://drobilla.net/software/${_pkgname}/"
license=('custom:ISC')
depends=('lilv' 'suil')
-makedepends=('git' 'gtk2' 'gtk3' 'gtkmm' 'jack' 'python' 'qt4' 'qt5-base')
+makedepends=('git' 'gtk2' 'gtk3' 'gtkmm' 'jack' 'python' 'qt5-base')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
optdepends=('gtk2: Gtk+ 2.x frontend'
'gtk3: Gtk+ 3.x frontend'
'gtkmm: Gtk++ 2.x frontend'
- 'qt4: Qt 4.x frontend'
'qt5-base: Qt 5.x frontend')
source=("${_pkgname}::git+http://git.drobilla.net/${_pkgname}.git"
'autowaf::git+https://gitlab.com/drobilla/autowaf.git')
@@ -39,8 +38,9 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
- CXXFLAGS+=' -std=c++11'
- python waf configure --prefix=/usr
+ python waf configure \
+ --prefix=/usr \
+ --no-qt4
python waf build $MAKEFLAGS
}