summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2024-01-29 00:32:13 -0300
committerRafael Fontenelle2024-01-29 00:32:13 -0300
commit0ae3da612c8c55cac74b32869308061550baaa83 (patch)
tree206db05e9f9634decd46e130ab2ac20369b8a15b
parent3260c1e92553df47be169bcfdc5eed4302320fe7 (diff)
downloadaur-0ae3da612c8c55cac74b32869308061550baaa83.tar.gz
Fix build for Python 3.11
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--remove-header-includes.patch12
3 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba226278abe5..e7c034c1fcb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = adonthell
pkgdesc = A 2D graphical, single player role playing game engine
pkgver = 0.3.8
- pkgrel = 1
+ pkgrel = 2
url = http://adonthell.nongnu.org/
arch = x86_64
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = swig
depends = sdl2_mixer
depends = sdl2_ttf
depends = python
options = emptydirs
source = http://savannah.nongnu.org/download/adonthell/adonthell-src-0.3.8.tar.gz
+ source = remove-header-includes.patch
sha256sums = c006f95bc58f095eff1a6b4bfc3ec96a455c76cdc8b64c4b2430ad7775c2ccec
+ sha256sums = 59254960e4d165dfb318e1fd7e3c075f2aaed144af025fd832de716c9d131e43
pkgname = adonthell
-
diff --git a/PKGBUILD b/PKGBUILD
index 0e169b37badb..51b72241e54f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,24 @@
pkgname=adonthell
pkgver=0.3.8
-pkgrel=1
+pkgrel=2
pkgdesc="A 2D graphical, single player role playing game engine"
arch=('x86_64')
url="http://adonthell.nongnu.org/"
-license=('GPL2')
+license=('GPL-2.0-or-later')
depends=('sdl2_mixer' 'sdl2_ttf' 'python')
makedepends=('swig')
options=('emptydirs')
-source=("http://savannah.nongnu.org/download/adonthell/$pkgname-src-$pkgver.tar.gz")
-sha256sums=('c006f95bc58f095eff1a6b4bfc3ec96a455c76cdc8b64c4b2430ad7775c2ccec')
+source=("http://savannah.nongnu.org/download/adonthell/$pkgname-src-$pkgver.tar.gz"
+ "remove-header-includes.patch")
+sha256sums=('c006f95bc58f095eff1a6b4bfc3ec96a455c76cdc8b64c4b2430ad7775c2ccec'
+ '59254960e4d165dfb318e1fd7e3c075f2aaed144af025fd832de716c9d131e43')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # Remove includes of removed and duplicate called headers
+ patch -p1 -i "${srcdir}/remove-header-includes.patch"
+}
build() {
cd $pkgname-$pkgver
diff --git a/remove-header-includes.patch b/remove-header-includes.patch
new file mode 100644
index 000000000000..a923a839ff01
--- /dev/null
+++ b/remove-header-includes.patch
@@ -0,0 +1,12 @@
+--- adonthell-0.3.8/src/python_class.h 2024-01-29 00:14:42.704257813 -0300
++++ adonthell-0.3.8/src/python_class.h 2024-01-29 00:15:19.061407147 -0300
+@@ -34,9 +34,6 @@
+
+ #include <locale.h>
+ #include "Python.h"
+-#include "compile.h"
+-#include "eval.h"
+-#include "node.h"
+ #include "fileops.h"
+
+ #ifndef SWIG