summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-08 22:31:37 -0600
committerBrian Bidulock2015-07-08 22:31:37 -0600
commit0b0ebefda78b11474a9cdb1e7be1d7a192239d0e (patch)
tree59f104fcaa051b269c506dab86eb0c200e947a78
downloadaur-0b0ebefda78b11474a9cdb1e7be1d7a192239d0e.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..911d128404bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bmpanel2
+ pkgdesc = A NETWM-compatible panel for X11
+ pkgver = 2.1pre1
+ pkgrel = 5
+ url = http://bmpanel2.googlecode.com/
+ arch = i686
+ arch = x86_64
+ license = custom:MIT
+ makedepends = cmake
+ makedepends = asciidoc
+ makedepends = python2
+ depends = libxext
+ depends = pango
+ optdepends = pygtk: configuration GUI
+ source = http://bmpanel2.googlecode.com/files/bmpanel2-2.1pre1.tar.gz
+ md5sums = 766ce5d3d6be427192fa11883b230eed
+
+pkgname = bmpanel2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f7e83a171b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer : SpepS <dreamspepser at yahoo dot it>
+# Contributor: nsf <no.smile.face@gmail.com>
+
+pkgname=bmpanel2
+pkgver=2.1pre1
+pkgrel=5
+pkgdesc="A NETWM-compatible panel for X11"
+arch=("i686" "x86_64")
+url="http://bmpanel2.googlecode.com/"
+license=('custom:MIT')
+depends=('libxext' 'pango')
+optdepends=('pygtk: configuration GUI')
+makedepends=('cmake' 'asciidoc' 'python2')
+source=("${url}files/$pkgname-$pkgver.tar.gz")
+md5sums=('766ce5d3d6be427192fa11883b230eed')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ [ -d bld ] || mkdir bld && cd bld
+
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RELEASE \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/bld"
+ make DESTDIR="$pkgdir/" install
+
+ # python2 fix
+ sed -i 's/env python/&2/' `find "$pkgdir" -name "*.py"`
+
+ # license
+ install -Dm644 ../COPYING \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}