summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2020-04-22 12:36:09 -0700
committerDonald Webster2020-04-22 12:47:00 -0700
commit0b32072ca5b85a49b8fd9b8edcb74d0e871a71e6 (patch)
treeb5d66709c7cd83a93224d6f387484040ed255731
downloadaur-0b32072ca5b85a49b8fd9b8edcb74d0e871a71e6.tar.gz
Initial version of package for calibre-server systemd service.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD23
-rw-r--r--calibre-server.service18
-rw-r--r--calibre-server.sysusers2
-rw-r--r--calibre-server.tmpfiles5
6 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97ea13b9f812
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = calibre-server-systemd
+ pkgdesc = Systemd service for calibre-server
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/kovidgoyal/calibre
+ arch = any
+ license = GPL
+ depends = calibre
+ source = calibre-server.service
+ source = calibre-server.tmpfiles
+ source = calibre-server.sysusers
+ sha256sums = 4d043544c00969a9c70ab603ef202384b2134974499fcbcb6c804b150a47af25
+ sha256sums = a436a979ca3a9e78bdc410bd0027d97956bfa8d2d4f2b7bdf3f7d2ed199dd6a8
+ sha256sums = 435d956100b7474133ec58764d7e9d8d641fbac0e623952769e9817d7187025d
+
+pkgname = calibre-server-systemd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..83f384c005a4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27292c5501ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jan Holthuis <holthuis.jan@googlemail.com>
+
+pkgname=calibre-server-systemd
+pkgver=1.0
+pkgrel=1
+pkgdesc="Systemd service for calibre-server"
+url="https://github.com/kovidgoyal/calibre"
+arch=('any')
+depends=('calibre')
+license=('GPL')
+source=('calibre-server.service'
+ 'calibre-server.tmpfiles'
+ 'calibre-server.sysusers')
+
+sha256sums=('4d043544c00969a9c70ab603ef202384b2134974499fcbcb6c804b150a47af25'
+ 'a436a979ca3a9e78bdc410bd0027d97956bfa8d2d4f2b7bdf3f7d2ed199dd6a8'
+ '435d956100b7474133ec58764d7e9d8d641fbac0e623952769e9817d7187025d')
+
+package() {
+ install -D -m 644 "${srcdir}/calibre-server.sysusers" "${pkgdir}/usr/lib/sysusers.d/calibre-server.conf"
+ install -D -m 644 "${srcdir}/calibre-server.service" "${pkgdir}/usr/lib/systemd/system/calibre-server.service"
+ install -D -m 644 "${srcdir}/calibre-server.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/calibre-server.conf"
+}
diff --git a/calibre-server.service b/calibre-server.service
new file mode 100644
index 000000000000..f986e4111fae
--- /dev/null
+++ b/calibre-server.service
@@ -0,0 +1,18 @@
+# Modifications to this file will be overwritten by the package, so
+# use a systemd override instead.
+#
+# /etc/systemd/system/calibre-server.service.d/override.conf
+
+[Unit]
+Description=Calibre Server Service
+Wants=network-online.target
+After=network-online.target
+
+[Service]
+User=calibre
+Group=calibre
+ExecStart=/usr/bin/calibre-server --port=8080 /srv/calibre
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/calibre-server.sysusers b/calibre-server.sysusers
new file mode 100644
index 000000000000..8cd503a78cb7
--- /dev/null
+++ b/calibre-server.sysusers
@@ -0,0 +1,2 @@
+u calibre - - /var/lib/calibre
+g calibre -
diff --git a/calibre-server.tmpfiles b/calibre-server.tmpfiles
new file mode 100644
index 000000000000..f77f9671d2b2
--- /dev/null
+++ b/calibre-server.tmpfiles
@@ -0,0 +1,5 @@
+# Override this file with a modified version in /etc/tmpfiles.d/
+d /var/lib/sonarr 0755 sonarr sonarr
+Z /var/lib/sonarr - sonarr sonarr
+Z /usr/lib/sonarr - sonarr sonarr
+L /var/log/sonarr - - - - /var/lib/sonarr/logs/