summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Nagy2022-08-09 20:53:56 +0000
committerRoland Nagy2022-08-09 20:53:56 +0000
commit0b365dabc71b2718b8fcc73e68e33156e49d2876 (patch)
tree4337e7012d053bb5e88f3c50b0b120620c552b6b
parent194b81dc7c72ff194188256ff3b2c29a4ad0424f (diff)
downloadaur-0b365dabc71b2718b8fcc73e68e33156e49d2876.tar.gz
remove python-dephell dependency
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c46d1f4301db..abba4fa8cc8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-pywhat
pkgdesc = Identify emails, IP addresses and more
pkgver = 5.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bee-san/pyWhat
arch = any
license = MIT
- makedepends = python-dephell
makedepends = python-setuptools
+ makedepends = python-poetry
depends = python
depends = python-click
depends = python-rich
optdepends = python-orjson: faster JSON serialization and deserialization
- source = python-pywhat-5.1.0.tar.gz::https://github.com/bee-san/pyWhat/archive/5.1.0.tar.gz
+ source = python-pywhat-5.1.0.tar.gz::https://github.com/bee-san/pyWhat/archive/refs/tags/5.1.0.tar.gz
sha256sums = 1e8d8052e007c30165b9cb51466dcdc1cfdea555aab0986bf7f11731095f1400
pkgname = python-pywhat
diff --git a/PKGBUILD b/PKGBUILD
index 90700557506b..25aae57d7d5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,40 @@
-# Maintainer: Nagy Roland <roliboy@protonmail.com>
+# Maintainer: Roland Nagy <roliboy@protonmail.com>
pkgname=python-pywhat
-_pkgname=pyWhat
pkgver=5.1.0
-pkgrel=1
+_pyproject_version=5.0.0
+pkgrel=2
pkgdesc="Identify emails, IP addresses and more"
arch=("any")
+url="https://github.com/bee-san/pyWhat"
+license=("MIT")
depends=(
"python"
"python-click"
"python-rich"
)
makedepends=(
- "python-dephell"
"python-setuptools"
+ "python-poetry"
)
optdepends=(
"python-orjson: faster JSON serialization and deserialization"
)
-url="https://github.com/bee-san/pyWhat"
-license=("MIT")
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=("1e8d8052e007c30165b9cb51466dcdc1cfdea555aab0986bf7f11731095f1400")
-prepare() {
- cd "${_pkgname}-${pkgver}"
- dephell deps convert --from pyproject.toml --to setup.py
-}
-
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "$srcdir/pyWhat-$pkgver"
+ poetry build
+
+ cd dist
+ tar xf "pywhat-$_pyproject_version.tar.gz"
+ cd "pywhat-$_pyproject_version"
python setup.py build
}
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir/pyWhat-$pkgver/dist/pywhat-$_pyproject_version"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "$srcdir/pyWhat-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-