summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2016-08-17 02:59:16 +0200
committerSwift Geek2016-08-17 02:59:16 +0200
commit0b449015b00fa32de865705c29a4c651e6fb775a (patch)
tree045c89e72af2243c69921cb63c7f799a0523ce35
downloadaur-0b449015b00fa32de865705c29a4c651e6fb775a.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..feb35dccea94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Aug 17 00:59:02 UTC 2016
+pkgbase = ncpamixer-git
+ pkgdesc = ncurses PulseAudio Mixer
+ pkgver = c03248b
+ pkgrel = 1
+ url = https://github.com/fulhax/ncpamixer
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = ncurses
+ depends = pulseaudio
+ source = git://github.com/fulhax/ncpamixer.git
+ md5sums = SKIP
+
+pkgname = ncpamixer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49661d22144b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Swift Geek
+pkgname=ncpamixer-git
+_pkgname=ncpamixer
+pkgver=c03248b
+pkgrel=1
+pkgdesc="ncurses PulseAudio Mixer"
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+url="https://github.com/fulhax/ncpamixer"
+license=('MIT')
+depends=('ncurses' 'pulseaudio')
+makedepends=('git' 'cmake')
+source=("git://github.com/fulhax/ncpamixer.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-parse --short HEAD # Fix to better comply with github display
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ #make DESTDIR="${pkgdir}" install
+ install -d "$pkgdir/usr/bin/"
+ install -m 755 "build/Linux/debug/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}