summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuval Adam2015-06-30 15:50:18 +0300
committerYuval Adam2015-06-30 15:50:18 +0300
commit0b4659f95c75954d3663ea78c844178af79183e3 (patch)
tree6ebf2e56d1872499e583c42de405c4978437c73d
downloadaur-0b4659f95c75954d3663ea78c844178af79183e3.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..780b3407a893
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gr-gsm-git
+ pkgdesc = Gnuradio blocks and tools for receiving GSM transmissions
+ pkgver = 92398cf
+ pkgrel = 1
+ url = https://github.com/ptrkrysik/gr-gsm
+ arch = any
+ license = unknown
+ makedepends = cmake
+ depends = gnuradio
+ depends = boost
+ depends = swig
+ depends = log4cpp
+ depends = python2-scipy
+ provides = gr-gsm
+ source = git+https://github.com/ptrkrysik/gr-gsm
+ sha1sums = SKIP
+
+pkgname = gr-gsm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0aadf73b2f75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Yuval Adam <yuval at y3xz dot com> PGP-Key: 271386AA2EB7672F
+
+pkgname=gr-gsm-git
+pkgver=92398cf
+pkgrel=1
+pkgdesc="Gnuradio blocks and tools for receiving GSM transmissions"
+arch=('any')
+url="https://github.com/ptrkrysik/gr-gsm"
+license=(unknown)
+depends=('gnuradio' 'boost' 'swig' 'log4cpp' 'python2-scipy')
+makedepends=('cmake')
+provides=('gr-gsm')
+source=('git+https://github.com/ptrkrysik/gr-gsm')
+sha1sums=('SKIP')
+_gitname=gr-gsm
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd $_gitname
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd $_gitname
+ cd build
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: