summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorent Thiéry2016-01-19 15:11:35 +0100
committerFlorent Thiéry2016-01-19 15:11:35 +0100
commit0b479f47f18ae2e82500dfd8640d8e8000ebbf3b (patch)
tree87fb65a4d23286f964a319543e24b97f97928015
downloadaur-0b479f47f18ae2e82500dfd8640d8e8000ebbf3b.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rw-r--r--keeweb-desktop.install7
-rw-r--r--keeweb.desktop13
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db316406df56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Jan 19 14:11:14 UTC 2016
+pkgbase = keeweb-desktop
+ pkgdesc = This webapp is a desktop password manager compatible with KeePass databases.
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/antelle/keeweb
+ install = keeweb-desktop.install
+ arch = x86_64
+ license = MIT
+ makedepends = imagemagick
+ source = https://github.com/antelle/keeweb/releases/download/v0.5.1/KeeWeb.linux.x64.zip
+ source = keeweb.desktop
+ source = keeweb-desktop.install
+ sha256sums = 4bed2321519ffbf9a35d1abe98cc7e3b4ea4c477fbb8a6ae2f2d4d8ccc040d46
+ sha256sums = 8fd3b677f5d9fd8c2992004cc01fb5629939c94ca81b43d347f8e57ac6c0a70b
+ sha256sums = 78c88e74b4e951d52f328656c6b12dbb1da5a73019a9f2d230be8d0cdfdcfda8
+
+pkgname = keeweb-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5f5d0cdc47a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: fthiery fthiery@gmail.com
+
+pkgname=keeweb-desktop
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="This webapp is a desktop password manager compatible with KeePass databases."
+arch=('x86_64')
+url="https://github.com/antelle/keeweb"
+makedepends=('imagemagick')
+license=('MIT')
+source=(
+ "${url}/releases/download/v${pkgver}/KeeWeb.linux.x64.zip"
+ "keeweb.desktop"
+ "keeweb-desktop.install"
+)
+sha256sums=(
+ '4bed2321519ffbf9a35d1abe98cc7e3b4ea4c477fbb8a6ae2f2d4d8ccc040d46'
+ '8fd3b677f5d9fd8c2992004cc01fb5629939c94ca81b43d347f8e57ac6c0a70b'
+ '78c88e74b4e951d52f328656c6b12dbb1da5a73019a9f2d230be8d0cdfdcfda8'
+)
+install=${pkgname}.install
+
+package(){
+ mkdir -p "${pkgdir}"/usr/share/${pkgname}
+ cp --preserve=mode -r * "${pkgdir}"/usr/share/${pkgname}
+ rm ${pkgdir}/usr/share/${pkgname}/KeeWeb.linux.x64.zip
+
+ #FIXME: should we generate thumbs ?
+ for res in 128x128 16x16 256x256 32x32 48x48; do
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/${res}/apps"
+ convert -resize ${res} -depth 8 "${pkgdir}/usr/share/${pkgname}/resources/app/icon.png" "${pkgdir}/usr/share/icons/hicolor/${res}/apps/keeweb.png"
+ #ln -s "/usr/share/keeweb-desktop/resources/app/icon.png" "${pkgdir}/usr/share/icons/hicolor/${res}/apps/keeweb.png"
+ done
+
+ install -dm755 "${pkgdir}/usr/share/applications"
+ install -Dm644 "keeweb.desktop" "${pkgdir}/usr/share/applications/keeweb.desktop"
+
+ mkdir -p "${pkgdir}"/usr/bin
+ echo -e "#!/bin/sh\n/usr/share/${pkgname}/KeeWeb" > ${pkgdir}/usr/bin/KeeWeb
+ chmod 755 ${pkgdir}/usr/bin/KeeWeb
+}
diff --git a/keeweb-desktop.install b/keeweb-desktop.install
new file mode 100644
index 000000000000..1d3667795f2a
--- /dev/null
+++ b/keeweb-desktop.install
@@ -0,0 +1,7 @@
+post_install() {
+ [ -e '/bin/gtk-update-icon-cache' ] && gtk-update-icon-cache /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/keeweb.desktop b/keeweb.desktop
new file mode 100644
index 000000000000..b8544c660e55
--- /dev/null
+++ b/keeweb.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Type=Application
+Name=KeeWeb Password Safe
+GenericName=Keepass2-compatible cross-platform password manager
+Comment=A web port of the free, open source, light-weight and easy-to-use password manager
+Exec=KeeWeb
+Icon=keeweb
+MimeType=application/x-keepass2;
+Terminal=false
+StartupNotify=false
+Categories=Utility;
+#StartupWMClass=KeePass2
+#X-Desktop-File-Install-Version=0.22