summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKasper Menten2017-01-12 16:15:57 +0100
committerKasper Menten2017-01-12 16:15:57 +0100
commit0b6573b1c53d68b04cf3a401c4e50e3e56a5a472 (patch)
tree97070c69970a68d773abde7d3bc5a48afab1af7c
downloadaur-0b6573b1c53d68b04cf3a401c4e50e3e56a5a472.tar.gz
adding shift transmission webui to aur
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abc3543c038e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = shift-git
+ pkgdesc = A minimalistic approach to maximum control of your Transmission. (Web UI)
+ pkgver = 0.9.9
+ pkgrel = 1
+ url = https://github.com/killemov/Shift
+ arch = i686
+ arch = x86_64
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = transmission-cli
+ provides = Shift=0.9.9
+ conflicts = kettu-git
+ source = Shift::git+https://github.com/killemov/Shift.git
+ md5sums = SKIP
+
+pkgname = shift-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf53073dfaa4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: gh0st <gh0st@vivaldi.net>
+
+_pkgname=Shift
+pkgname="shift-git"
+pkgver=0.9.9
+pkgrel=1
+pkgdesc='A minimalistic approach to maximum control of your Transmission. (Web UI)'
+arch=('i686' 'x86_64' 'any')
+url="https://github.com/killemov/$_pkgname"
+license=('GPL')
+depends=(transmission-cli)
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("kettu-git")
+source=("$_pkgname"::"git+https://github.com/killemov/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ #~ The repo doesn't have any releases or other tagged commits.
+ #~ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cat << EOF >| $_pkgname.conf
+[Service]
+Environment=TRANSMISSION_WEB_HOME=/usr/share/webapps/$_pkgname
+EOF
+}
+
+package() {
+ install -Dm644 $_pkgname.conf "$pkgdir/usr/lib/systemd/system/transmission.service.d/$_pkgname.conf"
+ install -dm755 "$pkgdir/usr/share/webapps/$_pkgname"
+
+ cd "$_pkgname"
+ cp -a * "$pkgdir/usr/share/webapps/$_pkgname"
+}