summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rodriguez Reboredo2023-05-21 12:40:23 -0300
committerMartin Rodriguez Reboredo2023-05-21 12:40:23 -0300
commit0b7eb41516318699f1afbafcd9ef30e19db0f20c (patch)
tree7393059dcb535dee27cd2ff7cdf446f3bc9ddfab
parent92d84982366b21761de94c94d7699be9826d5dc1 (diff)
downloadaur-0b7eb41516318699f1afbafcd9ef30e19db0f20c.tar.gz
Update to 5.10.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7080a108fe17..6c7bd7dfd652 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zulip-desktop-electron
pkgdesc = Real-time team chat based on the email threading model
- pkgver = 5.9.4
- pkgrel = 2
+ pkgver = 5.10.0
+ pkgrel = 1
url = https://zulip.com
arch = x86_64
license = Apache
@@ -12,10 +12,10 @@ pkgbase = zulip-desktop-electron
depends = libxss
provides = zulip-desktop
conflicts = zulip-desktop
- source = zulip-desktop-5.9.4.tar.gz::https://github.com/zulip/zulip-desktop/archive/v5.9.4.tar.gz
+ source = zulip-desktop-5.10.0.tar.gz::https://github.com/zulip/zulip-desktop/archive/v5.10.0.tar.gz
source = zulip-desktop.desktop
source = zulip-desktop.sh.in
- sha256sums = 4127a6a9bfef2acb8a6e9865e8d5d1e4033857029dad609a1cfa6cd4e68a278d
+ sha256sums = 03dde91bc8f8e8d750dcc0a240f0efda65578fb7d99ced0a04a47ec88bbc1f2e
sha256sums = 8f3440dc9195c6763de16f8b13409a5c130bdf417015e7e27bb64fdb227f4f10
sha256sums = 70ed0f08158c6ea8ef99dbbe360861e2c63911c2fadc74c0154bd6567abc8979
diff --git a/PKGBUILD b/PKGBUILD
index 2d6793649991..161d756fc702 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: aspen <aspen@aspenuwu.me>
pkgname=zulip-desktop-electron
-pkgver=5.9.4
-pkgrel=2
+pkgver=5.10.0
+pkgrel=1
_electronversion=22
pkgdesc="Real-time team chat based on the email threading model"
arch=('x86_64')
@@ -16,7 +16,7 @@ conflicts=("${pkgname%-*}")
source=("${pkgname%-*}-$pkgver.tar.gz::https://github.com/zulip/zulip-desktop/archive/v$pkgver.tar.gz"
"${pkgname%-*}.desktop"
"${pkgname%-*}.sh.in")
-sha256sums=('4127a6a9bfef2acb8a6e9865e8d5d1e4033857029dad609a1cfa6cd4e68a278d'
+sha256sums=('03dde91bc8f8e8d750dcc0a240f0efda65578fb7d99ced0a04a47ec88bbc1f2e'
'8f3440dc9195c6763de16f8b13409a5c130bdf417015e7e27bb64fdb227f4f10'
'70ed0f08158c6ea8ef99dbbe360861e2c63911c2fadc74c0154bd6567abc8979')
@@ -26,9 +26,8 @@ build() {
electronVer="$(sed s/^v// $electronDist/version)"
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
HOME="$srcdir/.electron-gyp" npm install --cache "$srcdir/npm-cache"
- ./node_modules/.bin/tsc
- ./node_modules/.bin/electron-builder --linux --x64 --dir \
- $dist -c.electronDist=$electronDist -c.electronVersion=$electronVer
+ npm run pack -- --linux --x64 \
+ -c.electronDist=$electronDist -c.electronVersion=$electronVer
}
package() {