summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-06-09 15:10:29 +0800
committerUniversebenzene2023-06-09 15:10:29 +0800
commit0b8161a64fe2a84e3c3925e3051161f861e64646 (patch)
treef9a08f51eee5166d5bd88daa8d388ed2e4733196
parentccc48a86a3f38501c032959c6abc6deed95e84fe (diff)
downloadaur-0b8161a64fe2a84e3c3925e3051161f861e64646.tar.gz
Update to version 0.21.0
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2323e0cf751a..936fee610c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@ pkgbase=python-scikit-image
_pname=${pkgbase#python-}
_pyname=${_pname/-/_}
pkgname=("python-${_pname}")
-pkgver=0.20.0
+pkgver=0.21.0
pkgrel=1
pkgdesc="Image processing routines for SciPy"
arch=('i686' 'x86_64')
url="http://scikit-image.org"
license=('BSD')
-makedepends=('cython>=0.29.24'
+makedepends=('cython>=0.29.32'
'python-setuptools'
'python-numpy'
'meson-python'
@@ -21,31 +21,32 @@ makedepends=('cython>=0.29.24'
'python-build'
'python-installer'
'python-pythran'
- 'python-packaging>=20.0')
-depends=('python-numpy>=1.21.1' 'python-scipy>=1.8' 'python-networkx>=2.8' 'python-pillow>=9.0.1' 'python-pywavelets>=1.1.1' 'python-imageio>=2.4.1' 'python-tifffile>=2019.7.26' 'python-packaging>=20.0' 'python-lazy-loader>=0.1')
+ 'python-packaging>=21')
+depends=('python-numpy>=1.21.1' 'python-scipy>=1.8' 'python-networkx>=2.8' 'python-pillow>=9.0.1' 'python-pywavelets>=1.1.1' 'python-imageio>=2.27' 'python-tifffile>=2022.8.12' 'python-packaging>=21' 'python-lazy-loader>=0.2')
checkdepends=('python-pytest>=5.2.0'
'python-pytest-cov>=2.7.0'
- 'python-matplotlib>=3.3'
+ 'python-matplotlib>=3.5'
# 'python-pytest-flake8'
- 'python-pytest-localserver')
-# 'python-pooch>=1.3.0')
+ 'python-pytest-localserver'
+ 'python-pooch>=1.6.0')
# 'python-pyqt5')
# 'python-pytest-faulthandler')
-optdepends=('python-matplotlib>=3.3'
+optdepends=('python-matplotlib>=3.5'
'freeimage: for reading various types of image file formats'
'python-pyamg: fast cg_mg mode of random walker segmentation'
- 'python-astropy>=3.1.2: Provides FITS I/O capability'
+ 'python-astropy>=5.0: Provides FITS I/O capability'
'python-simpleitk: Optional I/O plugin providing a wide variety of formats. including specialized formats using in medical imaging'
- 'python-dask>2.17.0: used to speed up certain functions'
+ 'python-dask>2021.1.0: used to speed up certain functions'
'python-cloudpickle>=0.2.1: necessary to provide the 'processes' scheduler for dask'
- 'python-pooch>=1.3.0')
+ 'python-pooch>=1.6.0'
+ 'python-scikit-learn>=0.24.0')
# 'python-imread: Optional I/O plugin providing most standard formats'
# 'python-pyqt5: for imshow[x, fancy=True] and skivi'
# 'pyside2: for imshow[x, fancy=True] and skivi'
# 'python-qtpy'
options=('!emptydirs')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('2cd784fce18bd31d71ade62c6221440199ead03acf7544086261ee032264cf61')
+sha256sums=('b33e823c54e6f11873ea390ee49ef832b82b9f70752c8759efd09d5a4e3d87f0')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"