summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2023-03-31 10:26:52 -0400
committerGuillaume Horel2023-03-31 10:27:02 -0400
commit0b82d471481c02f18b6d1a91278dfeb68818d7d3 (patch)
tree7c9f75931a8f0b8f05edaddfcd429dc9603d1d31
parent4a42f5ec921a6ac153138ee78e876fe84a832abf (diff)
downloadaur-0b82d471481c02f18b6d1a91278dfeb68818d7d3.tar.gz
fix parallel build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa8d9d72e27e..729a5bcfadd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
pkgver = 0.3.22
- pkgrel = 1
+ pkgrel = 2
url = http://www.openblas.net/
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index df0cb93b7ce7..e2bd42a55178 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgver=0.3.22
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.11.0
_blasver=3.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('x86_64')
url="http://www.openblas.net/"
@@ -31,7 +31,8 @@ _config="FC=gfortran USE_OPENMP=1 USE_THREAD=1 \
build(){
cd "${_PkgName}-${pkgver}"
- make ${_config} libs netlib shared
+ unset MAKEFLAGS
+ make ${_config} shared
}
package(){