summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0strodamus2015-12-08 13:02:04 -0700
committer0strodamus2015-12-08 13:02:04 -0700
commit0b8976a39c5963248f5f0600f2c9e385f717bf78 (patch)
tree286038e874e94c46bbf8fb23da585366574ea21d
downloadaur-0b8976a39c5963248f5f0600f2c9e385f717bf78.tar.gz
initial commit
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD61
-rw-r--r--engrampa.install13
-rwxr-xr-xengrampa.tap47
-rw-r--r--fr-rpm-bsdtar.patch60
5 files changed, 221 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d4c96a5db55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+# Generated by mksrcinfo v8
+# Tue Dec 8 20:00:10 UTC 2015
+pkgbase = engrampa-thunar
+ pkgdesc = Archive manipulator for MATE without Caja dependency (GTK2 version)
+ pkgver = 1.12.0
+ pkgrel = 1
+ url = http://mate-desktop.org
+ install = engrampa.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = mate-common
+ makedepends = yelp-tools
+ depends = bzip2
+ depends = desktop-file-utils
+ depends = gtk2
+ depends = gzip
+ depends = libarchive
+ depends = tar
+ optdepends = unrar: for RAR uncompression
+ optdepends = zip: for ZIP archives
+ optdepends = unzip: for ZIP archives
+ optdepends = p7zip: 7zip compression utility
+ optdepends = arj: for ARJ archives
+ optdepends = unace: extraction tool for the proprietary ace archive format
+ optdepends = yelp: for reading MATE help documents
+ optdepends = thunar-archive-plugin: create and extract archives in Thunar
+ provides = engrampa
+ conflicts = engrampa
+ replaces = engrampa
+ options = !emptydirs
+ source = http://pub.mate-desktop.org/releases//engrampa-1.12.0.tar.xz
+ source = fr-rpm-bsdtar.patch
+ source = engrampa.tap
+ sha1sums = 76e2ac2806c6dcf6744766df6f9d0c056df5e301
+ sha1sums = 219b05a979bf6f249aaae27964f02345fd81168d
+ sha1sums = 84f023a660c77cf046cff71d1d890f7de5af4110
+
+pkgname = engrampa-thunar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8384ecc5aa8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: 0strodamus <0strodamus at cox dot net>
+# Contributor: Rob McCathie <korrode AT gmail>
+# Contributor: n00b <dannyurvt (at) gmail.com>
+#
+# MATE Engrampa package without Caja dependency and with Thunar integration
+#
+# note: if you get "No suitable archive manager found" errors, you need
+# to adjust Xfce Settings > MIME Type Editor associations for Engrampa
+
+pkgname=engrampa-thunar
+_pkgname=engrampa
+pkgver=1.12.0
+_pkgver1.12
+pkgrel=1
+pkgdesc="Archive manipulator for MATE without Caja dependency (GTK2 version)"
+url="http://mate-desktop.org"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('bzip2' 'desktop-file-utils' 'gtk2' 'gzip' 'libarchive' 'tar')
+makedepends=('mate-common' 'yelp-tools')
+optdepends=('unrar: for RAR uncompression'
+ 'zip: for ZIP archives' 'unzip: for ZIP archives'
+ 'p7zip: 7zip compression utility' 'arj: for ARJ archives'
+ 'unace: extraction tool for the proprietary ace archive format'
+ 'yelp: for reading MATE help documents'
+ 'thunar-archive-plugin: create and extract archives in Thunar')
+provides=($_pkgname)
+conflicts=($_pkgname)
+replaces=($_pkgname)
+options=( '!emptydirs')
+source=("http://pub.mate-desktop.org/releases/${_pkgver}/${_pkgname}-${pkgver}.tar.xz"
+ 'fr-rpm-bsdtar.patch'
+ 'engrampa.tap')
+sha1sums=('76e2ac2806c6dcf6744766df6f9d0c056df5e301'
+ '219b05a979bf6f249aaae27964f02345fd81168d'
+ '84f023a660c77cf046cff71d1d890f7de5af4110')
+install=engrampa.install
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ # this patch 'depends' on libarchive
+ patch -Np1 -i "${srcdir}/fr-rpm-bsdtar.patch"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/${_pkgname} \
+ --with-gtk=2.0 \
+ --disable-static \
+ --disable-packagekit \
+ --disable-caja-actions -without-cajadir
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm755 ${srcdir}/engrampa.tap ${pkgdir}/usr/lib/xfce4/thunar-archive-plugin/engrampa.tap
+}
diff --git a/engrampa.install b/engrampa.install
new file mode 100644
index 000000000000..bf6781f93005
--- /dev/null
+++ b/engrampa.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas/
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/engrampa.tap b/engrampa.tap
new file mode 100755
index 000000000000..628f2de6140f
--- /dev/null
+++ b/engrampa.tap
@@ -0,0 +1,47 @@
+#!/bin/sh
+#
+# engrampa.tap - Wrapper script to create and extract archive files
+# in Thunar, via the thunar-archive-plugin, using the
+# engrampa archive manager.
+#
+# $Id: engrampa.tap 1468 2006-07-02 14:02:38Z benny $
+#
+# Copyright (c) 2006 Benedikt Meurer <benny@xfce.org>.
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the Free
+# Software Foundation; either version 2 of the License, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
+# more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place, Suite 330, Boston, MA 02111-1307 USA.
+#
+
+# determine the action and the folder, $@ then contains only the files
+action=$1; shift;
+folder=$1; shift;
+
+# check the action
+case $action in
+create)
+ exec engrampa "--default-dir=$folder" --add "$@"
+ ;;
+
+extract-here)
+ exec engrampa "--extract-to=$folder" --force "$@"
+ ;;
+
+extract-to)
+ exec engrampa --extract "$@"
+ ;;
+
+*)
+ echo "Unsupported action '$action'" >&2
+ exit 1
+esac
diff --git a/fr-rpm-bsdtar.patch b/fr-rpm-bsdtar.patch
new file mode 100644
index 000000000000..93a783176f3f
--- /dev/null
+++ b/fr-rpm-bsdtar.patch
@@ -0,0 +1,60 @@
+This makes Engrampa use bsdtar to extract .RPM packages instead of using cpio.
+It is useful on systems that do not have cpio or RPM/YUM
+This patch was created for Arch Linux, however should work on any system that has bsdtar capable of handling cpio archives.
+
+------------------+
+ rpm2cpio.c | 2 +-
+ fr-command-rpm.c | 8 ++++----
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+Index: src/commands/rpm2cpio.c
+================================
+--- mate-file-archiver-1.6.0/src/commands/rpm2cpio.c 2013-03-31
++++ mate-file-archiver-1.6.0/src/commands/rpm2cpio.c 2013-07-26
+@@ -128,7 +128,7 @@
+ archive_command = "bzip2 -dc";
+ fclose (stream);
+
+- command = g_strdup_printf ("sh -c \"dd if=%s ibs=%u skip=1 2>/dev/null | %s | cpio %s\"", g_shell_quote (filename), offset, archive_command, cpio_args->str);
++ command = g_strdup_printf ("sh -c \"dd if=%s ibs=%u skip=1 2>/dev/null | %s | bsdtar %s\"", g_shell_quote (filename), offset, archive_command, cpio_args->str);
+
+ return system (command);
+ }
+Index: src/fr-command-rpm.c
+================================
+--- mate-file-archiver-1.6.0/src/fr-command-rpm.c 2013-03-31
++++ mate-file-archiver-1.6.0/src/fr-command-rpm.c 2013-07-26
+@@ -175,7 +175,7 @@
+
+ fr_process_begin_command (comm->process, "sh");
+ fr_process_add_arg (comm->process, "-c");
+- fr_process_add_arg_concat (comm->process, PRIVEXECDIR "rpm2cpio ", comm->e_filename, " -itv", NULL);
++ fr_process_add_arg_concat (comm->process, PRIVEXECDIR "rpm2cpio ", comm->e_filename, " -tvf -", NULL);
+ fr_process_end_command (comm->process);
+ fr_process_start (comm->process);
+ }
+@@ -200,7 +200,7 @@
+
+ cmd = g_string_new (PRIVEXECDIR "rpm2cpio ");
+ g_string_append (cmd, comm->e_filename);
+- g_string_append (cmd, " -idu ");
++ g_string_append (cmd, " -xf - ");
+ for (scan = file_list; scan; scan = scan->next) {
+ char *filename = g_shell_quote (scan->data);
+ g_string_append (cmd, filename);
+@@ -233,7 +233,7 @@
+ FrCommandCap capabilities;
+
+ capabilities = FR_COMMAND_CAN_ARCHIVE_MANY_FILES;
+- if (is_program_available ("cpio", check_command))
++ if (is_program_available ("bsdtar", check_command))
+ capabilities |= FR_COMMAND_CAN_READ;
+
+ return capabilities;
+@@ -244,7 +244,7 @@
+ fr_command_rpm_get_packages (FrCommand *comm,
+ const char *mime_type)
+ {
+- return PACKAGES ("cpio,rpm");
++ return PACKAGES ("bsdtar,rpm");
+ }