summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-27 15:46:41 -0400
committerAlex Whitt2017-04-27 15:46:41 -0400
commit0b90837abd8b0d43ca9a5ddfb74c3921b7ed56e3 (patch)
tree7d4d7e3437f7877f02e8f6948b486b9a921b7134
downloadaur-0b90837abd8b0d43ca9a5ddfb74c3921b7ed56e3.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2fedd717ba9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Apr 27 19:46:13 UTC 2017
+pkgbase = emacs-python-environment
+ pkgdesc = Python virtualenv API for Emacs Lisp
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/tkf/emacs-python-environment
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-deferred
+ provides = emacs-python-environment
+ source = https://github.com/tkf/emacs-python-environment/archive/0.0.2.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-python-environment
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de46cc74410c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-python-environment
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Python virtualenv API for Emacs Lisp"
+url="https://github.com/tkf/emacs-python-environment"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-deferred')
+makedepends=('git')
+provides=('emacs-python-environment')
+source=("https://github.com/tkf/emacs-python-environment/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/emacs-python-environment-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile python-environment*.el
+}
+
+package() {
+ cd "${srcdir}/emacs-python-environment-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/python-environment"
+ install -m644 python-environment*.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/python-environment/"
+} \ No newline at end of file