summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3S0X2020-08-12 15:18:24 +0200
committerD3S0X2020-08-12 15:18:24 +0200
commit0bafad933753ffaad74387bb613868902c103e95 (patch)
tree569abd9075ff09e54e6db6aa614a12610b1ceefb
downloadaur-0bafad933753ffaad74387bb613868902c103e95.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27dbad5c6566
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = whitesur-cursor-theme-git
+ pkgdesc = WhiteSur cursors theme for linux desktops
+ pkgver = r3.1ada17d
+ pkgrel = 1
+ url = https://github.com/vinceliuice/WhiteSur-cursors
+ arch = any
+ license = GPL3
+ makedepends = git
+ source = git+https://github.com/vinceliuice/WhiteSur-cursors.git
+ sha256sums = SKIP
+
+pkgname = whitesur-cursor-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..171d3f3cde70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Nico <desoxhd@gmail.com>
+pkgname="whitesur-cursor-theme-git"
+_gitname=WhiteSur-cursors
+pkgver=r3.1ada17d
+pkgrel=1
+pkgdesc="WhiteSur cursors theme for linux desktops"
+arch=("any")
+makedepends=('git')
+url="https://github.com/vinceliuice/${_gitname}"
+license=('GPL3')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/icons/"
+ cp -pr "${srcdir}/${_gitname}/dist" "${pkgdir}/usr/share/icons/${_gitname}"
+}