summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPer Osbäck2018-07-09 16:37:54 +0200
committerPer Osbäck2018-07-09 16:43:53 +0200
commit0be8858ce8f37017b5ba741c15c7ae81272d3597 (patch)
treee5d5c6e73be83a717f2e67c0a05f9e6c9e66b0e1
parent646079faa26281f468d056e1a830980a5bbffe15 (diff)
downloadaur-0be8858ce8f37017b5ba741c15c7ae81272d3597.tar.gz
fix for when no GOPATH is set
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0b077418f74..84314a1183e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = perfops-cli
pkgdesc = A simple command line tool to interact with hundreds of servers around the world. Run benchmarks and debug your infrastructure without leaving your console.
pkgver = 0.7.5
- pkgrel = 1
+ pkgrel = 2
url = https://perfops.net
arch = x86_64
license = APACHE
diff --git a/PKGBUILD b/PKGBUILD
index f405b1d25ec7..86095d660c90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Per Osbeck <per@osbeck.com>
pkgname=perfops-cli
pkgver=0.7.5
-pkgrel=1
+pkgrel=2
pkgdesc="A simple command line tool to interact with hundreds of servers around the world. Run benchmarks and debug your infrastructure without leaving your console."
arch=(x86_64)
url="https://perfops.net"
@@ -12,12 +12,13 @@ md5sums=(SKIP)
build() {
cd "$pkgname"
- PERFOPS_BUILD_PLATFORMS=linux bash hack/build-all.sh
+ GOPATH="$srcdir" PERFOPS_BUILD_PLATFORMS=linux bash hack/build-all.sh
}
-# check() {
-# #
-# }
+prepare() {
+ mkdir -p "src/github.com/ProspectOne"
+ ln -sf "$srcdir/$pkgname" "src/github.com/ProspectOne/$pkgname"
+}
package() {
cd "$pkgname"