summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorben Günther2020-10-09 19:02:27 +0200
committerThorben Günther2020-10-09 19:02:27 +0200
commit0bff61dde7f1ddb366c50bdcfaa99a63b321ed2b (patch)
tree99fcc53b38d48f0ad5d94a0866830f75e78306bf
parentbaad867571b9981594d814a1745d3211229fd9b4 (diff)
downloadaur-0bff61dde7f1ddb366c50bdcfaa99a63b321ed2b.tar.gz
upgpkg: mako-git v1.4.1.r41.g071ed01-1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD35
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bbd002c73c2..f1418dbde089 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = mako-git
pkgdesc = Lightweight notification daemon for Wayland
- pkgver = r430.bf6d462
+ pkgver = v1.4.1.r41.g071ed01
pkgrel = 1
url = http://mako-project.org
arch = x86_64
license = MIT
makedepends = meson
makedepends = scdoc
+ makedepends = systemd
makedepends = wayland-protocols
makedepends = git
+ depends = gdk-pixbuf2
depends = pango
depends = cairo
+ depends = systemd-libs
depends = wayland
optdepends = jq: support for 'makoctl menu'
provides = mako
diff --git a/PKGBUILD b/PKGBUILD
index 8c324676fead..49682f2155ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Thorben Günther <echo YWRtaW5AeGVucm94Lm5ldAo= | base64 -d>
+# Contributor: Drew DeVault <sir@cmpwn.com>
pkgname=mako-git
_pkgname=mako
-pkgver=r430.bf6d462
+pkgver=v1.4.1.r41.g071ed01
pkgrel=1
license=('MIT')
pkgdesc='Lightweight notification daemon for Wayland'
-makedepends=("meson" "scdoc" "wayland-protocols" "git")
+makedepends=("meson" "scdoc" "systemd" "wayland-protocols" "git")
depends=(
- "pango"
- "cairo"
- "wayland"
+ "gdk-pixbuf2"
+ "pango"
+ "cairo"
+ "systemd-libs"
+ "wayland"
)
optdepends=("jq: support for 'makoctl menu'")
arch=("x86_64")
@@ -20,18 +23,22 @@ provides=('mako')
conflicts=('mako')
pkgver() {
- cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long 2> /dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
- cd "$_pkgname"
- meson --prefix=/usr . build
- ninja -C build
+ cd "$_pkgname"
+ arch-meson -D zsh-completions=true build
+ ninja -C build
}
package() {
- cd "$_pkgname"
- DESTDIR="$pkgdir/" ninja -C build install
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"${pkgname%-*}"/LICENSE
+ cd "$_pkgname"
+ DESTDIR="$pkgdir/" ninja -C build install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"${pkgname%-*}"/LICENSE
}