summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Golovin2015-09-20 22:57:14 +0300
committerRoman Golovin2015-09-20 23:00:29 +0300
commit0bffa70d7c6ba609b6002d07ff87a4238a04d38f (patch)
tree574f0b1957fd7d4cac14eec690ee73926d8c6471
downloadaur-0bffa70d7c6ba609b6002d07ff87a4238a04d38f.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--ttf-weather-icons.install20
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b25a0e4a790e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-weather-icons
+ pkgdesc = Icon font with 222 weather themed icons
+ pkgver = 2.0.10
+ pkgrel = 1
+ url = https://erikflowers.github.io/weather-icons/
+ install = ttf-weather-icons.install
+ arch = any
+ license = custom:"OFL"
+ source = https://github.com/erikflowers/weather-icons/archive/2.0.10.tar.gz
+ source = LICENSE::http://scripts.sil.org/cms/scripts/render_download.php?format=file&media_id=OFL_plaintext&filename=OFL.txt
+ sha256sums = 51fc93425a61754b34ce298158de28984ad5904e58d42bbfc225704edde20d02
+ sha256sums = SKIP
+
+pkgname = ttf-weather-icons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da0ca9d1679a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Roman Golovin <https://wiki.archlinux.org/index.php/Special:EmailUser/Dantix>
+
+pkgname=ttf-weather-icons
+pkgver=2.0.10
+pkgrel=1
+
+pkgdesc="Icon font with 222 weather themed icons"
+url="https://erikflowers.github.io/weather-icons/"
+license=('custom:"OFL"')
+
+arch=('any')
+source=("https://github.com/erikflowers/weather-icons/archive/$pkgver.tar.gz"
+ "LICENSE::http://scripts.sil.org/cms/scripts/render_download.php?format=file&media_id=OFL_plaintext&filename=OFL.txt")
+sha256sums=('51fc93425a61754b34ce298158de28984ad5904e58d42bbfc225704edde20d02' 'SKIP')
+install=$pkgname.install
+
+package() {
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd weather-icons-$pkgver/font
+ install -d "$pkgdir"/usr/share/fonts/TTF
+ install -m644 *.ttf "$pkgdir"/usr/share/fonts/TTF
+}
diff --git a/ttf-weather-icons.install b/ttf-weather-icons.install
new file mode 100644
index 000000000000..da3bd53a7174
--- /dev/null
+++ b/ttf-weather-icons.install
@@ -0,0 +1,20 @@
+post_install() {
+ printf 'Updating font cache...'
+ fc-cache -s > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ printf 'done\n'
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*