summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShizcow2020-07-24 16:20:02 -0600
committerShizcow2020-07-24 16:20:02 -0600
commit0c000c52a3bec1aab87f9002885734f528ab3e35 (patch)
tree15d56411868312347e3dc0bf9b16acb8c9826eee
parentb8fb57897490a7ac573fb2b567003e148ea6ce86 (diff)
downloadaur-0c000c52a3bec1aab87f9002885734f528ab3e35.tar.gz
The comment section on the AUR exists for a reason
-rw-r--r--PKGBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cc11e72febf..76da827706b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,7 +43,6 @@ md5sums=('SKIP')
pkgver() {
cd $_pkgbase
- git checkout develop > /dev/null
# first get the version number
cat config.mk | grep "VERSION" | grep -Po '(\d+\.)?(\d+\.)?(\*|\d+)' | tr -d '\n'
# then get the commit hash from development branch
@@ -52,14 +51,13 @@ pkgver() {
prepare() (
cd $_pkgbase
- git config advice.detachedHead false
+ git config pull.ff only
git checkout develop > /dev/null
git pull
)
build() (
cd $_pkgbase
- git checkout develop
make PLUGINS="$PLUGINS"
)