summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-06-24 00:01:04 +0200
committerFabioLolix2022-06-24 00:01:04 +0200
commit0c2be79bd4abd8831642acba56333d9f0ed0a0bb (patch)
tree6239303df96d012d92101ea5595580cc72b8ae31
parent26452c711956bc3d306e814735c198a684e04ad5 (diff)
downloadaur-0c2be79bd4abd8831642acba56333d9f0ed0a0bb.tar.gz
v0.16.3.2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c327963f432..46d9c78465eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gamehub
pkgdesc = Games manager, downloader, library that supports GOG, Steam and Humble Bundle
- pkgver = 0.16.1.2
- pkgrel = 2
+ pkgver = 0.16.3.2
+ pkgrel = 1
url = https://tkashkin.github.io/projects/gamehub/
arch = i686
arch = x86_64
@@ -9,9 +9,10 @@ pkgbase = gamehub
arch = armv7h
arch = aarch64
license = GPL3
+ makedepends = git
makedepends = meson
makedepends = ninja
- makedepends = vala0.54
+ makedepends = vala
depends = gtk3
depends = glib2
depends = libgee
@@ -23,7 +24,7 @@ pkgbase = gamehub
depends = libxtst
options = !strip
options = debug
- source = GameHub-0.16.1.2.tar.gz::https://github.com/tkashkin/GameHub/archive/0.16.1-2-master.tar.gz
- sha256sums = bbbf2f5216ce6f0d6a57179f388a714aec52188f4e67a9deb6478061441a30b5
+ source = git+https://github.com/tkashkin/GameHub.git#tag=0.16.3-2-master
+ sha256sums = SKIP
pkgname = gamehub
diff --git a/PKGBUILD b/PKGBUILD
index e4ee5e99c38b..a4b287e247a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,27 @@
# Contributor: Robert Stoffers <rstoffers@gmail.com>
pkgname=gamehub
-_pkgver=0.16.1-2
+_pkgver=0.16.3-2
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="Games manager, downloader, library that supports GOG, Steam and Humble Bundle"
arch=(i686 x86_64 armv6h armv7h aarch64)
url="https://tkashkin.github.io/projects/gamehub/"
license=(GPL3)
depends=(gtk3 glib2 libgee libsoup json-glib sqlite webkit2gtk libmanette libxtst)
-makedepends=(meson ninja vala0.54)
+makedepends=(git meson ninja vala)
options=(!strip debug)
-source=("GameHub-$pkgver.tar.gz::https://github.com/tkashkin/GameHub/archive/${_pkgver}-master.tar.gz")
-sha256sums=('bbbf2f5216ce6f0d6a57179f388a714aec52188f4e67a9deb6478061441a30b5')
+#source=("git+https://github.com/tkashkin/GameHub/archive/${_pkgver}-master.tar.gz")
+source=("git+https://github.com/tkashkin/GameHub.git#tag=${_pkgver}-master")
+sha256sums=('SKIP')
build() {
- cd "GameHub-$_pkgver-master"
+ cd "GameHub"
CFLAGS="$CFLAGS -O0" meson . build --prefix=/usr -Ddistro=arch --buildtype=debug
ninja -C build
}
package() {
- cd "GameHub-$_pkgver-master"
+ cd "GameHub"
DESTDIR="${pkgdir}" ninja -C build install
}