summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhirui Dai2023-10-15 01:40:58 -0700
committerZhirui Dai2023-10-15 01:40:58 -0700
commit0c36ec3fd7e9feed4b06fbfad6c4dea2d78d8932 (patch)
tree321e9f8ce8892226b3dc3ba640a876319399dc5b
parent2f6fc6fc9aac85f503cf2ad1a3eae26c23b280bb (diff)
downloadaur-0c36ec3fd7e9feed4b06fbfad6c4dea2d78d8932.tar.gz
fix build
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 10 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc4b3a5de774..9dcc6a920cd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = ffmpeg-cuda
pkgdesc = Complete solution to record, convert and stream audio and video. Includes cuda support.
pkgver = 6.0
- pkgrel = 1
- epoch = 1
+ pkgrel = 2
url = https://ffmpeg.org/
arch = x86_64
license = custom
@@ -90,9 +89,7 @@ pkgbase = ffmpeg-cuda
provides = libswscale.so
provides = ffmpeg
conflicts = ffmpeg
- source = ffmpeg-cuda-6.0.tar.xz::https://ffmpeg.org/releases/ffmpeg-6.0.tar.xz
- source = libavcodec.patch
- sha256sums = 57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082
- sha256sums = 4a5cda5821a89527f764fe5a0404dada0e4058f4f6b1a7afe28c14229d3aee9f
+ source = git+https://git.ffmpeg.org/ffmpeg.git#commit=1e888462a1ea2b3f1144b536fd2702d95759ba43
+ sha256sums = SKIP
pkgname = ffmpeg-cuda
diff --git a/PKGBUILD b/PKGBUILD
index 768761d692e4..e06f772053bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,7 @@
pkgname=ffmpeg-cuda
pkgver=6.0
-pkgrel=1
-epoch=1
+pkgrel=2
pkgdesc='Complete solution to record, convert and stream audio and video. Includes cuda support.'
arch=(x86_64)
url=https://ffmpeg.org/
@@ -112,25 +111,17 @@ provides=(
)
conflicts=('ffmpeg')
source=(
- "${pkgname}-${pkgver}.tar.xz::https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"
- 'libavcodec.patch'
-)
-sha256sums=(
- "57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082"
- "4a5cda5821a89527f764fe5a0404dada0e4058f4f6b1a7afe28c14229d3aee9f"
+ "git+https://git.ffmpeg.org/ffmpeg.git#commit=1e888462a1ea2b3f1144b536fd2702d95759ba43"
)
+sha256sums=("SKIP")
-_dir=ffmpeg-${pkgver}
-prepare() {
- cd $_dir
- patch -p1 -i ${srcdir}/libavcodec.patch
-}
+_dir=ffmpeg
build() {
local _cflags='-I/opt/cuda/include'
local _ldflags='-L/opt/cuda/lib64'
- local _nvccflags='-gencode arch=compute_52,code=sm_52 -O2'
+ #local _nvccflags='-gencode arch=compute_52,code=sm_52 -O2'
# local _nvccflags='-arch=sm_52 \
# -gencode arch=compute_52,code=sm_52 \
@@ -149,12 +140,12 @@ build() {
# -O2'
cd ${_dir}
-
+ export PATH="/opt/cuda/bin:$PATH"
+ #--nvccflags="$_nvccflags" \
./configure \
--prefix=/usr \
--extra-cflags="$_cflags" \
--extra-ldflags="$_ldflags" \
- --nvccflags="$_nvccflags" \
--disable-debug \
--disable-static \
--disable-stripping \