summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-04 12:57:29 -0400
committerAlex Whitt2017-05-04 12:57:29 -0400
commit0c52d52baa8eca79e5d8334032b33ee6a73ae602 (patch)
tree94b944fb11fe26e3e7e8698cdb39a69b5587b2a2
parent1b8f577367aa076bf90039f841a66f3396f5b8be (diff)
downloadaur-0c52d52baa8eca79e5d8334032b33ee6a73ae602.tar.gz
Adding sha256sums and install script
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD3
-rw-r--r--emacs-all-the-icons.install18
3 files changed, 23 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 813993b166dd..5744fcd7bb57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Wed May 3 19:48:01 UTC 2017
+# Thu May 4 16:56:30 UTC 2017
pkgbase = emacs-all-the-icons
pkgdesc = A utility package to collect various Icon Fonts and propertize them within Emacs.
pkgver = 2.5.0
pkgrel = 2
url = https://github.com/domtronn/all-the-icons.el
+ install = emacs-all-the-icons.install
arch = any
license = MIT
makedepends = git
@@ -18,7 +19,7 @@ pkgbase = emacs-all-the-icons
depends = ttf-all-the-icons
provides = emacs-all-the-icons
source = https://github.com/domtronn/all-the-icons.el/archive/2.5.0.tar.gz
- sha256sums = SKIP
+ sha256sums = 9d8c96b316a0e4ba04f474e6bf1a567a2b92ef696d3872192d26abce1aa187bc
pkgname = emacs-all-the-icons
diff --git a/PKGBUILD b/PKGBUILD
index f2a9b38b8f60..1033600cd8aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,8 @@ depends=('emacs' 'emacs-font-lock-plus' 'ttf-font-awesome' 'ttf-material-design-
makedepends=('git')
provides=('emacs-all-the-icons')
source=("https://github.com/domtronn/all-the-icons.el/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+sha256sums=('9d8c96b316a0e4ba04f474e6bf1a567a2b92ef696d3872192d26abce1aa187bc')
+install=${pkgname}.install
build() {
cd "${srcdir}/all-the-icons.el-${pkgver}"
diff --git a/emacs-all-the-icons.install b/emacs-all-the-icons.install
new file mode 100644
index 000000000000..5ce385e19a7d
--- /dev/null
+++ b/emacs-all-the-icons.install
@@ -0,0 +1,18 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'all-the-icons)
+
+==> Or, with use-package:
+
+(use-package all-the-icons)
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}