summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2017-02-15 00:31:18 +0100
committerStefan Husmann2017-02-15 00:31:18 +0100
commit0c5bd637423a4a47f9d5f8c056f5f060788bde76 (patch)
tree19bcb5a8d6cb3ef7cbd9312361a0442f6667c525
downloadaur-0c5bd637423a4a47f9d5f8c056f5f060788bde76.tar.gz
initial upload
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a1ef5c8a9ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = clx-truetype
+ pkgdesc = Use truetype fonts in common lisp
+ pkgver = 20160701
+ pkgrel = 1
+ url = http://filonenko-mikhail.github.io/clx-truetype/
+ arch = any
+ license = custom:unknown
+ source = git+https://github.com/filonenko-mikhail/clx-truetype.git#commit=c6e10a918d46632324d5863a8ed067a83fc26de8
+ md5sums = SKIP
+
+pkgname = clx-truetype
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cea0d3620839
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=clx-truetype
+pkgver=20160701
+pkgrel=1
+pkgdesc="Use truetype fonts in common lisp"
+arch=('any')
+url="http://filonenko-mikhail.github.io/clx-truetype/"
+license=('custom:unknown')
+source=("git+https://github.com/filonenko-mikhail/clx-truetype.git#commit=c6e10a918d46632324d5863a8ed067a83fc26de8")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ echo $(git log -1 --format="%cd" --date=short | sed 's|-||g')
+}
+
+package() {
+ cd ${pkgname}
+ install -d ${pkgdir}/usr/share/doc/$pkgname/
+ install -m644 doc/$pkgname.{pdf,html} ${pkgdir}/usr/share/doc/$pkgname/
+ install -d ${pkgdir}/usr/share/common-lisp/source/${pkgname}
+ install -d ${pkgdir}/usr/share/common-lisp/systems
+
+ install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${pkgname} *.lisp
+ install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${pkgname} *.asd
+
+ cd ${pkgdir}/usr/share/common-lisp/systems
+ ln -s ../source/${pkgname}/${pkgname}.asd .
+ ln -s ../source/${pkgname}/${pkgname}-unicode.asd .
+}