summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Sutter2022-09-25 07:01:31 -0400
committerBen Sutter2022-09-25 07:01:31 -0400
commit0c65ccad782f106b1cc9aaeb67bb773aa7f3ad5e (patch)
tree7cfb9b246d1822df7ca40a744941d6be2e577a08
parent1c85d20fc56602848629254caa681a9292f09988 (diff)
downloadaur-0c65ccad782f106b1cc9aaeb67bb773aa7f3ad5e.tar.gz
add xdg config file
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD13
-rw-r--r--guile-hall-git-xdg-fix.patch55
4 files changed, 70 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f2ca921e03a..36a2cdfefbf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guile-hall-git
pkgdesc = Project manager and build tool for GNU guile (Git snapshot)
pkgver = 0.4.1.r30.g36dd0c6
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/a-sassmannshausen/guile-hall
arch = i686
arch = x86_64
@@ -15,6 +15,8 @@ pkgbase = guile-hall-git
provides = guile-hall=0.4.1.r30.g36dd0c6
options = !strip
source = guile-hall::git+https://gitlab.com/a-sassmannshausen/guile-hall.git
+ source = guile-hall-git-xdg-fix.patch
sha256sums = SKIP
+ sha256sums = 0ea14d5f9fcf8ccf81c6235be643109671d7db691e3f8e55eca4d1326851224d
pkgname = guile-hall-git
diff --git a/.gitignore b/.gitignore
index cdfaa8ed1245..f0e7efda09d9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,6 @@
*
!.gitignore
!PKGBUILD
+!guile-hall-git-xdg-fix.patch
!.SRCINFO
-#end \ No newline at end of file
+#end
diff --git a/PKGBUILD b/PKGBUILD
index e2d60e61a586..19659759dfea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=guile-hall-git
pkgver=0.4.1.r30.g36dd0c6
-pkgrel=1
+pkgrel=2
pkgdesc="Project manager and build tool for GNU guile (Git snapshot)"
arch=('i686' 'x86_64' 'aarch64')
license=('GPL')
@@ -11,9 +11,11 @@ makedepends=('git')
depends=('guile' 'guile-config' 'texinfo')
optdepends=('guix: for GNU Guix integration')
provides=("guile-hall=$pkgver")
-source=("${pkgname%-git}::git+https://gitlab.com/a-sassmannshausen/guile-hall.git")
+source=("${pkgname%-git}::git+https://gitlab.com/a-sassmannshausen/guile-hall.git"
+ "guile-hall-git-xdg-fix.patch")
url="https://gitlab.com/a-sassmannshausen/guile-hall"
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ '0ea14d5f9fcf8ccf81c6235be643109671d7db691e3f8e55eca4d1326851224d')
options=(!strip)
pkgver() {
@@ -21,6 +23,11 @@ pkgver() {
git describe --tags | sed 's+-+.r+' | sed 's+^v++' | tr - .
}
+prepare() {
+ cd ${pkgname%-git}
+ git apply ../guile-hall-git-xdg-fix.patch
+}
+
build() {
cd ${pkgname%-git}
autoreconf -vif
diff --git a/guile-hall-git-xdg-fix.patch b/guile-hall-git-xdg-fix.patch
new file mode 100644
index 000000000000..8dfb32a6939c
--- /dev/null
+++ b/guile-hall-git-xdg-fix.patch
@@ -0,0 +1,55 @@
+commit a219be1da65ac527d839db0c74f2c0bb6774ae84
+Author: Ben Sutter <14796185+bms-1984@users.noreply.github.com>
+Date: Sun Sep 25 06:45:27 2022 -0400
+
+ add xdg config file
+
+diff --git a/doc/hall.texi b/doc/hall.texi
+index 5bc876a..e2fdaca 100644
+--- a/doc/hall.texi
++++ b/doc/hall.texi
+@@ -334,7 +334,7 @@ The special switches @option{--help}, @option{--version},
+ @option{--usage} and @option{--cmdtree} are always available. They
+ will act as your guides as you explore the lands of Hall.
+ @item
+-Hall has a configuration file located at @file{~/.hall}. You can set
++Hall has a configuration file located at @file{~/.hall} or at @file{~/.config/hall/hall}. You can set
+ some settings there, to provide default values for all your projects.
+ @end itemize
+
+@@ -362,8 +362,8 @@ convert an existing Guile project to use Hall (using the
+
+ Outside of the standard options, @command{init} also accepts
+ @option{--author}, @option{--license}, @option{--prefix} and
+-@option{--website}. All of these can be set in the @file{~/.hall}
+-configuration file.
++@option{--website}. All of these can be set in the @file{~/.hall} and @file{~/.config/hall/hall}
++configuration files.
+
+ It also accepts the special @option{--convert} switch, which will
+ probably become a subcommand in the near future.
+diff --git a/scripts/hall.in b/scripts/hall.in
+index d14269e..90c0c1e 100644
+--- a/scripts/hall.in
++++ b/scripts/hall.in
+@@ -149,8 +149,7 @@ distribution file.")
+ create a new project. You can use a number of arguments (see above) to
+ provide additional metadata — but the project name is mandatory.
+
+-Defaults for the author, prefix, website & license arguments can be set in the
+-~/.hall configuration file.
++Defaults for the author, prefix, website & license arguments can be set in ~/.hall or ~/.config/hall/hall.
+
+ '--convert' can be used when you have an existing project that you want to
+ start using hall for.
+@@ -221,7 +220,9 @@ first.")
+ (handler (cut string-split <> #\,))
+ (synopsis "CSV list regexp patterns to indicate files to skip.")
+ (example "scripts/foo,AUTHORS,^.*rgp$")))))))
+- (directory (in-home "."))
++ (directory (list
++ (in-home ".config/hall/" #t)
++ (in-home "." #t)))
+ (parser simple-sexp-parser)))
+
+ (define* (main #:optional (args (command-line)))