summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-21 12:17:04 +0000
committerBioArchLinuxBot2023-06-21 12:17:04 +0000
commit0cadba0c80579a6103bfc8938aabb9aa45ec27b7 (patch)
tree2b120fefc632c4524d88ade752ef383acacd9ad7
parent7e2bcabb0903f27efb3304af093da8df34e49d76 (diff)
downloadaur-0cadba0c80579a6103bfc8938aabb9aa45ec27b7.tar.gz
[lilac] updated to 2.1.8-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0c7ee7152ab..63695f704b6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = diamond
pkgdesc = High performance sequence aligner for protein and translated DNA searches with big sequence data. https://doi.org/10.1038/s41592-021-01101-x
- pkgver = 2.1.7
+ pkgver = 2.1.8
pkgrel = 1
url = https://github.com/bbuchfink/diamond
arch = x86_64
@@ -10,7 +10,8 @@ pkgbase = diamond
depends = zlib
depends = zstd
depends = blast+
- source = diamond-2.1.7.tar.gz::https://github.com/bbuchfink/diamond/archive/v2.1.7.tar.gz
- sha256sums = 2dcaba0e79ecb02c3d2a6816d317e714767118a9a056721643abff4c586ca95b
+ depends = glibc
+ source = diamond-2.1.8.tar.gz::https://github.com/bbuchfink/diamond/archive/v2.1.8.tar.gz
+ sha256sums = b6088259f2bc92d1f9dc4add44590cff68321bcbf91eefbc295a3525118b9415
pkgname = diamond
diff --git a/PKGBUILD b/PKGBUILD
index 219bd352e126..7dc613a332dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
# shellcheck disable=2148
pkgname=diamond
-pkgver=2.1.7
+pkgver=2.1.8
pkgrel=1
pkgdesc="High performance sequence aligner for protein and translated DNA searches with big sequence data. https://doi.org/10.1038/s41592-021-01101-x"
arch=('x86_64')
url="https://github.com/bbuchfink/diamond"
license=('GPL3')
-depends=('gcc-libs' 'zlib' 'zstd' 'blast+')
+depends=('gcc-libs' 'zlib' 'zstd' 'blast+' 'glibc')
makedepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/bbuchfink/diamond/archive/v$pkgver.tar.gz")
-sha256sums=('2dcaba0e79ecb02c3d2a6816d317e714767118a9a056721643abff4c586ca95b')
+sha256sums=('b6088259f2bc92d1f9dc4add44590cff68321bcbf91eefbc295a3525118b9415')
build() {
cd $pkgname-$pkgver
@@ -29,6 +29,11 @@ build() {
cmake --build build
}
+check() {
+ cd $pkgname-$pkgver
+ ctest --test-dir build --output-on-failure
+}
+
package() {
cd $pkgname-$pkgver
DESTDIR="$pkgdir" cmake --install build