summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-12 17:42:13 +0100
committerNarrat2020-01-12 17:42:13 +0100
commit0cb2b1643ce43e8a0151b88abd393402a7efda27 (patch)
tree6b12cd81cb53f4ee8245f6df0a2fdb0dd66d0cfe
parent74c712df70e7b5621b1b32a86cb22d1bdb540b45 (diff)
downloadaur-0cb2b1643ce43e8a0151b88abd393402a7efda27.tar.gz
Follow Arch community PKGBUILD
Patch adapted without testing. So be warned
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
-rw-r--r--keybinder.patch62
-rw-r--r--xfce4-notifyd.install14
4 files changed, 50 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fde4f20ea40..8ca29b0cae14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = xfce4-notifyd-keyaction
pkgdesc = Notification daemon for the Xfce desktop. Super+N executes the first action
- pkgver = 0.2.4
+ pkgver = 0.4.4
pkgrel = 1
- url = http://goodies.xfce.org/projects/applications/xfce4-notifyd
- install = xfce4-notifyd.install
+ url = https://goodies.xfce.org/projects/applications/xfce4-notifyd
arch = i686
arch = x86_64
groups = xfce4-goodies
@@ -13,13 +12,13 @@ pkgbase = xfce4-notifyd-keyaction
depends = libnotify
depends = hicolor-icon-theme
depends = libkeybinder3
+ provides = xfce4-notifyd
provides = notification-daemon
conflicts = xfce4-notifyd
- replaces = xfce4-notifiyd
- source = http://archive.xfce.org/src/apps/xfce4-notifyd/0.2/xfce4-notifyd-0.2.4.tar.bz2
+ source = https://archive.xfce.org/src/apps/xfce4-notifyd/0.4/xfce4-notifyd-0.4.4.tar.bz2
source = keybinder.patch
- sha256sums = 8c7ed62f9496816d1391281f77d1b32216f9bf6fd22fbe4f6f3f4e07a6bbced0
- sha256sums = c6c040602ff207ebf3ed73edc50ae67d905485867bf79f11361c18ffc224cca1
+ sha256sums = 090571acf94c423003426cb779fb23e8545c68bab6485563b589c7def8a21b55
+ sha256sums = 9fb16fe3806dc985b51002f13ac96c940252609b98b4f6a2647a7a01bf768f80
pkgname = xfce4-notifyd-keyaction
diff --git a/PKGBUILD b/PKGBUILD
index 7b2f28eae278..a6fcbe8405b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,41 @@
+# Contributor: Alejandro Perez Mendez <alejandro.perez.mendez@gmail.com>
+
+_pkgname=xfce4-notifyd
pkgname=xfce4-notifyd-keyaction
-srcname=xfce4-notifyd
-pkgver=0.2.4
+pkgver=0.4.4
pkgrel=1
pkgdesc="Notification daemon for the Xfce desktop. Super+N executes the first action"
arch=('i686' 'x86_64')
-url="http://goodies.xfce.org/projects/applications/xfce4-notifyd"
+url="https://goodies.xfce.org/projects/applications/xfce4-notifyd"
license=('GPL2')
groups=('xfce4-goodies')
depends=('libxfce4ui' 'libnotify' 'hicolor-icon-theme' 'libkeybinder3')
makedepends=('intltool')
-replaces=('xfce4-notifiyd')
conflicts=('xfce4-notifyd')
-provides=('notification-daemon')
-install=$srcname.install
-source=(http://archive.xfce.org/src/apps/$srcname/0.2/$srcname-$pkgver.tar.bz2
+provides=('xfce4-notifyd' 'notification-daemon')
+source=(https://archive.xfce.org/src/apps/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2
keybinder.patch)
-sha256sums=('8c7ed62f9496816d1391281f77d1b32216f9bf6fd22fbe4f6f3f4e07a6bbced0'
- 'c6c040602ff207ebf3ed73edc50ae67d905485867bf79f11361c18ffc224cca1')
+sha256sums=('090571acf94c423003426cb779fb23e8545c68bab6485563b589c7def8a21b55'
+ '9fb16fe3806dc985b51002f13ac96c940252609b98b4f6a2647a7a01bf768f80')
-build() {
- cd "$srcdir/$srcname-$pkgver"
- patch -i ../../keybinder.patch -p1
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -Np1 -i ../keybinder.patch
+}
+
+build() {
+ cd "$_pkgname-$pkgver"
./configure \
--prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
--disable-static \
--disable-debug
make
}
package() {
- cd "$srcdir/$srcname-$pkgver"
+ cd "$_pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
diff --git a/keybinder.patch b/keybinder.patch
index d9d80d017162..b75a24b7abf3 100644
--- a/keybinder.patch
+++ b/keybinder.patch
@@ -1,21 +1,18 @@
-diff --git a/./Makefile.in b/tmp/xfce4-notifyd.KEY/src/xfce4-notifyd-0.2.4/Makefile.in
-index 40aa4a7..5dbc91d 100644
---- a/./Makefile.in
-+++ b/tmp/xfce4-notifyd.KEY/src/xfce4-notifyd-0.2.4/Makefile.in
-@@ -522,7 +522,8 @@ common_ldadd = \
+--- xfce4-notifyd-0.4.4/Makefile.in
++++ xfce4-notifyd-0.4.4/Makefile.in
+@@ -634,7 +634,8 @@
$(LIBXFCE4UTIL_LIBS) \
+ $(XFCONF_LIBS) \
$(LIBXFCE4UI_LIBS) \
- $(DBUS_GLIB_LIBS) \
-- $(XFCONF_LIBS)
-+ $(XFCONF_LIBS) \
+- $(GTK3_LIBS)
++ $(GTK3_LIBS) \
+ -lkeybinder
xfce4_notifyd_xfce4_notifyd_LDADD = \
$(common_ldadd) \
-diff --git a/./xfce4-notifyd/main.c b/tmp/xfce4-notifyd.KEY/src/xfce4-notifyd-0.2.4/xfce4-notifyd/main.c
-index 8fab30a..2750c5f 100644
---- a/./xfce4-notifyd/main.c
-+++ b/tmp/xfce4-notifyd.KEY/src/xfce4-notifyd-0.2.4/xfce4-notifyd/main.c
+
+--- xfce4-notifyd-0.4.4/xfce4-notifyd/main.c
++++ xfce4-notifyd-0.4.4/xfce4-notifyd/main.c
@@ -32,6 +32,7 @@
#include <xfconf/xfconf.h>
#include <libxfce4util/libxfce4util.h>
@@ -24,20 +21,19 @@ index 8fab30a..2750c5f 100644
#include "xfce-notify-daemon.h"
-@@ -67,6 +68,8 @@ main(int argc,
-
+@@ -45,6 +46,8 @@
+ xfconf_init(NULL);
+
gtk_init(&argc, &argv);
-
-+ keybinder_init();
+
++ keybinder_init();
+
xfce_textdomain(GETTEXT_PACKAGE, LOCALEDIR, "UTF-8");
- if(argc > 1) {
-diff --git a/./xfce4-notifyd/xfce-notify-daemon.c b/tmp/xfce4-notifyd.KEY/src/xfce4-notifyd-0.2.4/xfce4-notifyd/xfce-notify-daemon.c
-index ec2972a..c27057b 100644
---- a/./xfce4-notifyd/xfce-notify-daemon.c
-+++ b/tmp/xfce4-notifyd.KEY/src/xfce4-notifyd-0.2.4/xfce4-notifyd/xfce-notify-daemon.c
-@@ -86,6 +86,33 @@ enum
+
+--- xfce4-notifyd-0.4.4/xfce4-notifyd/xfce-notify-daemon.c
++++ xfce4-notifyd-0.4.4/xfce4-notifyd/xfce-notify-daemon.c
+@@ -94,6 +94,32 @@
URGENCY_CRITICAL,
};
@@ -67,34 +63,31 @@ index ec2972a..c27057b 100644
+ }
+}
+
-+
static void xfce_notify_daemon_screen_changed(GdkScreen *screen,
gpointer user_data);
static void xfce_notify_daemon_update_reserved_rectangles(gpointer key,
-@@ -367,6 +394,9 @@ xfce_notify_daemon_finalize(GObject *obj)
- dbus_g_connection_unref(xndaemon->dbus_conn);
+@@ -485,6 +511,8 @@
+ g_object_unref(xndaemon->settings);
G_OBJECT_CLASS(xfce_notify_daemon_parent_class)->finalize(obj);
+
+ keybinder_unbind(EXAMPLE_KEY, handler);
-+
}
-@@ -1239,6 +1269,8 @@ xfce_notify_daemon_start(XfceNotifyDaemon *xndaemon,
- "/org/freedesktop/Notifications",
- G_OBJECT(xndaemon));
+@@ -1578,6 +1606,8 @@
+ G_CALLBACK(xfce_notify_daemon_settings_changed),
+ xndaemon);
+ keybinder_bind(EXAMPLE_KEY, handler, xndaemon);
+
return TRUE;
}
-diff --git a/./xfce4-notifyd/xfce-notify-window.c b/tmp/xfce4-notifyd.KEY/src/xfce4-notifyd-0.2.4/xfce4-notifyd/xfce-notify-window.c
-index 285a70e..773fa9e 100644
---- a/./xfce4-notifyd/xfce-notify-window.c
-+++ b/tmp/xfce4-notifyd.KEY/src/xfce4-notifyd-0.2.4/xfce4-notifyd/xfce-notify-window.c
-@@ -118,6 +118,14 @@ static guint signals[N_SIGS] = { 0, };
+
+--- xfce4-notifyd-0.4.4/xfce4-notifyd/xfce-notify-window.c
++++ xfce4-notifyd-0.4.4/xfce4-notifyd/xfce-notify-window.c
+@@ -121,6 +121,14 @@
G_DEFINE_TYPE(XfceNotifyWindow, xfce_notify_window, GTK_TYPE_WINDOW)
@@ -109,4 +102,3 @@ index 285a70e..773fa9e 100644
static void
xfce_notify_window_class_init(XfceNotifyWindowClass *klass)
-
diff --git a/xfce4-notifyd.install b/xfce4-notifyd.install
deleted file mode 100644
index abf924aa24fc..000000000000
--- a/xfce4-notifyd.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-
-
-# vim:set ts=2 sw=2 et: