summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2022-09-16 17:29:28 +0200
committerÉtienne Deparis2022-09-16 17:29:28 +0200
commit0cdd54eba846d69f971a64d43286d778d99a3b45 (patch)
tree69c933eea8f5b9fcc954a1db0a5ecb253ef1735c
downloadaur-0cdd54eba846d69f971a64d43286d778d99a3b45.tar.gz
1.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ee98ab4d0d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by makepkg 6.0.1
+# Fri Sep 16 15:28:47 UTC 2022
+pkgbase = edgar-ssh
+ pkgdesc = A small utility to maintain SSH config files
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://git.umaneti.net/edgar/about/
+ arch = any
+ license = WTFPL
+ makedepends = python-setuptools
+ depends = python-yaml
+ source = https://git.umaneti.net/edgar/snapshot/edgar-1.1.tar.gz
+ sha256sums = 7cb686afdf9e94f586b93f54d88905331bbcdbdc929207e9b312eb362aab171a
+
+pkgname = edgar-ssh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a68b963fb4cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+pkgname=edgar-ssh
+_upname=edgar
+pkgver=1.1
+pkgrel=1
+pkgdesc="A small utility to maintain SSH config files"
+arch=("any")
+url="https://git.umaneti.net/${_upname}/about/"
+license=("WTFPL")
+depends=("python-yaml")
+makedepends=("python-setuptools")
+source=("https://git.umaneti.net/${_upname}/snapshot/${_upname}-${pkgver}.tar.gz")
+sha256sums=('7cb686afdf9e94f586b93f54d88905331bbcdbdc929207e9b312eb362aab171a')
+
+package() {
+ cd "${_upname}-$pkgver"
+ python setup.py install --no-compile --root=$pkgdir
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${_upname}/LICENSE"
+}