summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Souza2021-11-14 00:36:06 -0300
committerDaniel Souza2021-11-14 00:36:49 -0300
commit0cfca5681f827bb674b3192a877ee48238c1c479 (patch)
treed50cb93b7d516bcdfafacc066a1be9d02c7144a4
parent6134366850595bd635156a67a8e04519ef259774 (diff)
downloadaur-0cfca5681f827bb674b3192a877ee48238c1c479.tar.gz
Fix issues with 'arbie.install'
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--arbie.install22
3 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b792d900a2c8..3c8736fefe5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arbie-git
pkgdesc = Automatic Robust Backup, an archiving and synchronization tool.
- pkgver = v1.0.1.r0.g6f49e02
- pkgrel = 5
+ pkgver = v1.1.r5.g3fe90f2
+ pkgrel = 1
url = https://github.com/danisztls/arbie
install = arbie.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index a69da1fa3e11..0770ef47fd6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_gitbranch=main
_gitauthor=danisztls
pkgname=arbie-git
-pkgver=v1.0.1.r0.g6f49e02
-pkgrel=5
+pkgver=v1.1.r5.g3fe90f2
+pkgrel=1
pkgdesc="Automatic Robust Backup, an archiving and synchronization tool."
arch=('any')
license=('MIT')
diff --git a/arbie.install b/arbie.install
index aeb2ce14ecf5..d499fa7280f3 100644
--- a/arbie.install
+++ b/arbie.install
@@ -1,17 +1,24 @@
# based on https://github.com/archlinux/svntogit-community/tree/packages/profile-sync-daemon/trunk
# shellcheck disable=SC2016 # don't wish them to expand
-users=$(loginctl --no-legend list-users | awk '{ print $2 }' | sed ':a;N;$!ba;s/\n/ /g')
+# users=($(loginctl --no-legend list-users | awk '{ print $2 }' | sed ':a;N;$!ba'))
+mapfile -t users < <(loginctl --no-legend list-users | awk '{ print $2 }' | sed ':a;N;$!ba')
+
+# pre_install() {
+# }
+
+# post_install() {
+# }
pre_upgrade() {
- # stop system service now since it will be removed upon updating
- if systemctl is-active arbie.service &>/dev/null; then
- systemctl stop arbie.service &>/dev/null
- fi
+ # stop system service now since it will be removed upon updating
+ if systemctl is-active arbie.service &>/dev/null; then
+ systemctl stop arbie.service &>/dev/null
+ fi
}
post_upgrade() {
- _daemon_refresh
+ _daemon_refresh
}
pre_remove() {
@@ -22,6 +29,9 @@ pre_remove() {
done
}
+# post_remove() {
+# }
+
_daemon_refresh() {
for user in "${users[@]}"; do
su "$user" -s /bin/sh -c 'XDG_RUNTIME_DIR=/run/user/$UID systemctl --user daemon-reload'