summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Oelmueller2020-01-03 21:13:24 +0100
committerChris Oelmueller2020-01-03 21:48:35 +0100
commit0d13ad4dbacb0f555961e2fd5f24688deca18043 (patch)
tree947f213becb34671c6365c6294c10bdd58a24801
parent94ae5cb2688db914be8a718ffc38dc106be8ca89 (diff)
downloadaur-0d13ad4dbacb0f555961e2fd5f24688deca18043.tar.gz
fife-git: Update PKGBUILD for swig4
People still updating or building this are likely to have updated their SWIG by now. If you're reading this from the future: Yeah, me lazy again! Via https://github.com/fifengine/fifengine/commit/d14f232f4cd9a00b05
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD23
-rw-r--r--swig4.patch22
3 files changed, 55 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 509197341539..3d7fe0431bfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fife-git
pkgdesc = The mission of the FIFE project is to create a cross platform game creation framework
- pkgver = 0.4.1.r372.g85626ccd
+ pkgver = 0.4.2.r25.gc29d418a
pkgrel = 1
url = http://www.fifengine.net/
arch = i686
@@ -8,28 +8,32 @@ pkgbase = fife-git
license = LGPL
makedepends = cmake
makedepends = git
- depends = sdl2
+ makedepends = swig>=4
depends = boost
- depends = sdl2_ttf
- depends = sdl2_image
- depends = libvorbis
- depends = libogg
- depends = openal
- depends = swig
+ depends = fifechan>=0.1.4
+ depends = glew
depends = python
depends = python-future
- depends = zlib
depends = libgl
+ depends = libogg
depends = libpng
+ depends = libvorbis
+ depends = sdl2
+ depends = sdl2_ttf
+ depends = sdl2_image
+ depends = openal
depends = tinyxml
- depends = glew
- depends = fifechan-git
+ depends = zlib
provides = fife
provides = fife-svn
conflicts = fife
conflicts = fife-svn
source = git+https://github.com/fifengine/fifengine.git
+ source = swig4.patch
md5sums = SKIP
+ md5sums = 05b0425ae3a94a36b9227f51c09c23aa
+ sha1sums = SKIP
+ sha1sums = 0302be0b353e6aa69a81a8e8c872239ecbcab1d0
pkgname = fife-git
diff --git a/PKGBUILD b/PKGBUILD
index d2ac627bfb73..2cf51ec25d94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,33 @@ provides=("fife" "fife-svn")
conflicts=("fife" "fife-svn")
pkgdesc="The mission of the FIFE project is to create a cross platform game creation framework"
url="http://www.fifengine.net/"
-pkgver=0.4.1.r372.g85626ccd
+pkgver=0.4.2.r25.gc29d418a
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
-depends=('sdl2' 'boost' 'sdl2_ttf' 'sdl2_image' 'libvorbis' 'libogg' 'openal' 'swig' 'python' 'python-future' 'zlib' 'libgl' 'libpng' 'tinyxml' 'glew' 'fifechan-git')
-makedepends=('cmake' 'git')
-source=(git+https://github.com/fifengine/fifengine.git)
-md5sums=('SKIP')
+depends=('boost' 'fifechan>=0.1.4' 'glew' 'python' 'python-future'
+ 'libgl' 'libogg' 'libpng' 'libvorbis'
+ 'sdl2' 'sdl2_ttf' 'sdl2_image' 'openal' 'tinyxml' 'zlib')
+# # # TO BUILD WITH swig<4 SIMPLY REMOVE THE PATCH FROM prepare() # # #
+makedepends=('cmake' 'git' 'swig>=4')
+source=(git+https://github.com/fifengine/fifengine.git
+ "swig4.patch")
+md5sums=('SKIP'
+ '05b0425ae3a94a36b9227f51c09c23aa')
+sha1sums=('SKIP'
+ '0302be0b353e6aa69a81a8e8c872239ecbcab1d0')
+
pkgver() {
cd "$srcdir/fifengine"
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/fifengine"
+ patch -p1 -i "${srcdir}/swig4.patch"
+}
+
build() {
cd "$srcdir/fifengine"
# [TODO] Due to severe laziness, I have not tested in-source builds yet
diff --git a/swig4.patch b/swig4.patch
new file mode 100644
index 000000000000..d2318e71aa80
--- /dev/null
+++ b/swig4.patch
@@ -0,0 +1,22 @@
+From d14f232f4cd9a00b05d6872957070e8c020f515d Mon Sep 17 00:00:00 2001
+From: Thomas Kowaliczek-Schmer <linuxdonald@posteo.de>
+Date: Wed, 22 May 2019 16:04:43 +0200
+Subject: [PATCH] removed flags that are not supported with swig 4.0
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 126322ce0..25c695630 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -893,7 +893,7 @@ if(build-python)
+ find_package(PythonLibs ${PYTHON_VERSION_STRING} EXACT)
+ include_directories(${PYTHON_INCLUDE_PATH})
+
+- set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -nosafecstrings -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -nobuildnone -keyword -w511 -w473 -w404 -w314)
++ set(CMAKE_SWIG_FLAGS -fastdispatch -dirvtable -fastproxy -keyword -w511 -w473 -w404 -w314)
+
+ set_source_files_properties("${PROJECT_BINARY_DIR}/fife.i" PROPERTIES CPLUSPLUS ON)
+ set(FIFE_SOURCES ${FIFE_CORE_SRC})