summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2020-03-04 16:56:38 +0300
committerAnton Kudelin2020-03-04 16:56:38 +0300
commit0d16fe724af6dc711b57b55e3297709f44de9d17 (patch)
treee1cd8e257ddda0832cd82d01406d7d82483042d8
downloadaur-0d16fe724af6dc711b57b55e3297709f44de9d17.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d09a8fabe437
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-gspread-pandas
+ pkgdesc = A package to easily open an instance of a Google spreadsheet and interact with worksheets through Pandas DataFrames
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = https://github.com/aiguofer/gspread-pandas
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/aiguofer/gspread-pandas/archive/v2.2.1.tar.gz
+ sha256sums = 9890daf48795803f166afed0b9b66d7f8d95da36b6180187cb04736b2022b6cd
+
+pkgname = python-gspread-pandas
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc4483ac684b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+
+_pkgname=gspread-pandas
+pkgname=python-$_pkgname
+pkgver=2.2.1
+pkgrel=1
+pkgdesc='A package to easily open an instance of a Google spreadsheet and interact with worksheets through Pandas DataFrames'
+url="https://github.com/aiguofer/$_pkgname"
+arch=('any')
+license=('BSD')
+depends=('python')
+makedepends=('python-setuptools')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('9890daf48795803f166afed0b9b66d7f8d95da36b6180187cb04736b2022b6cd')
+
+build(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}