summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2020-12-08 16:16:11 +0100
committerL.G. Sarmiento2020-12-08 16:16:11 +0100
commit0d27e780e8d7869e63c65f1fe234776de4d5ee9a (patch)
tree8820328a3738a0f8c3ddd6949a79c146e15fe803
parent71a062064d30c3cca514eed7d34ac66423d8b817 (diff)
downloadaur-0d27e780e8d7869e63c65f1fe234776de4d5ee9a.tar.gz
compiles again, 2020-12-08. root 6.22.02-6
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.config.patch16
-rw-r--r--PKGBUILD23
3 files changed, 36 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index def3eae9d232..50a1964eceba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Nov 22 17:43:41 UTC 2019
+# Tue Dec 8 15:14:54 UTC 2020
pkgbase = go4
pkgdesc = Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT
pkgver = 6.0.0
@@ -8,11 +8,11 @@ pkgbase = go4
arch = x86_64
license = GPL
depends = root
- depends = qt5-base
+ depends = qt5-webengine
source = http://web-docs.gsi.de/~go4/download/go4-6.0.0.tar.gz
source = Makefile.config.patch
sha256sums = 28e3ecccbbde5a9168e85d6b6b5abaa147c0d65ea70332cdaaa80050ad61c55f
- sha256sums = d03fd394378e4ee97d2d17071010df046f1e9346d7b57585a694410a25bc5883
+ sha256sums = 4f30aaffccd27ca206d5633a3b637736fbe9f34258435db6446a0c43e1f51abd
pkgname = go4
diff --git a/Makefile.config.patch b/Makefile.config.patch
index dfbae65bfa74..bdc053594808 100644
--- a/Makefile.config.patch
+++ b/Makefile.config.patch
@@ -1,6 +1,14 @@
--- src/go4-6.0.0/Makefile.config 2019-10-25 12:45:46.709957747 +0200
-+++ Makefile.config 2019-11-22 18:15:33.517213237 +0100
-@@ -130,7 +130,7 @@
++++ Makefile.config 2019-12-19 21:09:15.698546160 +0100
+@@ -78,6 +78,7 @@
+ endif
+ endif
+
++INCLUDES += -I/usr/include
+
+ ifdef USEHDF5
+ INCLUDES += -I$(HDF5INCLUDEPATH)
+@@ -130,7 +131,7 @@
QMAKEOPTFLAG = "CONFIG+=release"
@@ -9,7 +17,7 @@
ifeq ($(GO4_OS),Win32)
QMAKEFLAGS += "INCLUDEPATH+=$(shell cygpath -w $(ROOTINCPATH))" "DEPENDPATH+=$(shell cygpath -w $(ROOTINCPATH))"
-@@ -277,7 +277,7 @@
+@@ -277,7 +278,7 @@
-lMinuit \
$(if $(USESPECTRUM),-lSpectrum,) \
$(if $(USEXMLIO),-lXMLIO,) \
@@ -18,7 +26,7 @@
ifneq ($(USERT),false)
LIBS_BASESET += -lrt
-@@ -296,7 +296,7 @@
+@@ -296,7 +297,7 @@
$(if $(USEDIM),-L$(DIMLIBPATH) -ldim,) \
$(if $(LINKX11),-L/usr/X11R6/lib/ -lX11,) \
$(if $(GO4_X11),-L/usr/lib/ -lX11,) \
diff --git a/PKGBUILD b/PKGBUILD
index 9f74658e790b..5767fb87fb10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@ pkgver=6.0.0
pkgrel=1
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
arch=('x86_64')
-depends=('root' 'qt5-base')
+depends=('root' 'qt5-webengine')
url="https://www.gsi.de/en/work/research/experiment_electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz"
"Makefile.config.patch")
sha256sums=('28e3ecccbbde5a9168e85d6b6b5abaa147c0d65ea70332cdaaa80050ad61c55f'
- 'd03fd394378e4ee97d2d17071010df046f1e9346d7b57585a694410a25bc5883')
+ '4f30aaffccd27ca206d5633a3b637736fbe9f34258435db6446a0c43e1f51abd')
prepare() {
@@ -30,6 +30,25 @@ prepare() {
# something change and the libraries are not found now at compilation time
patch -Np2 < ${srcdir}/Makefile.config.patch
+ # gSystem not found
+ sed -i '1s;^;#include <TSystem.h>\n;' Go4ThreadManager/TGo4AppControlTimer.cxx
+
+ # something with time
+ sed -i '1s;^;#include <TDatime.h>\n;' Go4ConditionsBase/TGo4Condition.cxx
+ sed -i '1s;^;#include <TDatime.h>\n;' Go4AnalysisClient/TGo4AnalysisClientImp.cxx
+
+ # error: incomplete type ‘TF1’ used in nested name specifier
+ sed -i 's;#include "TLatex.h";&\n#include "TF1.h";g' Go4Proxies/TGo4BrowserProxy.cxx
+ sed -i 's;#include "TLatex.h";&\n#include "TF1.h";g' qt4/Go4GUI/TGo4ViewPanel.cpp
+
+ # multiple definition of `fLogFile'
+ sed -i 's;#include "rawapin.h";;g' MbsAPI/f_evt.c
+
+ # error: ‘gVirtualX’ was not declared in this scope
+ sed -i '1s;^;#include "TVirtualX.h"\n;' qt4/Go4QtRoot/QRootWindow.cpp
+
+ # error: invalid use of incomplete type ‘class TObjString’
+ sed -i '1s;^;#include "TObjString.h"\n;' qt4/Go4QtRoot/QRootCanvas.cpp
}
build() {