summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorariasuni2017-10-17 01:53:16 +0200
committerariasuni2017-10-17 01:56:28 +0200
commit0d32f6fbb67a74a768ea7d2e9a5084c3b6d86c26 (patch)
treea27eb38215925e2b4352495394d8146fe98aa482
downloadaur-0d32f6fbb67a74a768ea7d2e9a5084c3b6d86c26.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD56
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78cc1640836b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = hunspell-fr
+ pkgdesc = French hunspell dictionary
+ pkgver = 6.1
+ pkgrel = 1
+ url = http://www.dicollecte.org/
+ arch = any
+ license = MPL2
+ optdepends = hunspell: the spell checking libraries and apps
+ provides = hunspell-fr
+ conflicts = hunspell-fr
+ source = http://www.dicollecte.org/download/fr/hunspell-french-dictionaries-v6.1.zip
+ sha256sums = 0c6acc29d3ec88feed4e4772af4521af1d52ce3fb092e685d474486e06fc5070
+
+pkgname = hunspell-fr-classical
+
+pkgname = hunspell-fr-comprehensive
+
+pkgname = hunspell-fr-modern
+
+pkgname = hunspell-fr-revised
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16863be6ff02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
+
+pkgbase='hunspell-fr'
+pkgname=($pkgbase-{'classical','comprehensive','modern','revised'})
+pkgver=6.1
+pkgrel=1
+pkgdesc="French hunspell dictionary"
+arch=(any)
+url="http://www.dicollecte.org/"
+license=('MPL2')
+optdepends=('hunspell: the spell checking libraries and apps')
+conflicts=('hunspell-fr')
+provides=('hunspell-fr')
+source=(${url}download/fr/hunspell-french-dictionaries-v${pkgver}.zip)
+sha256sums=('0c6acc29d3ec88feed4e4772af4521af1d52ce3fb092e685d474486e06fc5070')
+
+package_hunspell-fr-classical() {
+ _package 'classical' 'classique'
+}
+
+package_hunspell-fr-comprehensive() {
+ _package 'comprehensive' 'toutesvariantes'
+}
+
+package_hunspell-fr-modern() {
+ _package 'modern' 'moderne'
+}
+
+package_hunspell-fr-revised() {
+ _package 'revised' 'reforme1990'
+}
+
+_package() {
+ pkgdesc="${pkgdesc} ($1 variant)"
+ cd "${srcdir}"
+ install -dm755 ${pkgdir}/usr/share/hunspell
+ install -m644 fr-$2.dic ${pkgdir}/usr/share/hunspell/fr_FR.dic
+ install -m644 fr-$2.aff ${pkgdir}/usr/share/hunspell/fr_FR.aff
+
+ pushd "${pkgdir}"/usr/share/hunspell/
+ aliases="fr_BE fr_CA fr_CH fr_LU"
+ for lang in ${aliases}; do
+ ln -s fr_FR.aff ${lang}.aff
+ ln -s fr_FR.dic ${lang}.dic
+ done
+ popd
+
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd ${pkgdir}/usr/share/myspell/dicts
+ for file in ${pkgdir}/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename ${file}) .
+ done
+ popd
+
+ install -Dm644 README_dict_fr.txt "${pkgdir}"/usr/share/doc/${pkgname}/README_dict_fr.txt
+}