summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2018-05-03 02:48:57 -0400
committerskydrome2018-05-03 02:48:57 -0400
commit0d47a1ff8985103cf2f5e78bdfe0983bbf2e21ad (patch)
tree5ce8202c529a4bb37702a0594ccca04c4893a8cc
parent3e0e0f6001e19814f408692e739214a038d7d3ad (diff)
downloadaur-0d47a1ff8985103cf2f5e78bdfe0983bbf2e21ad.tar.gz
2.3.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--lazyman.install14
3 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d23106d724f..05f4d2ed301f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Mar 27 19:09:07 UTC 2018
pkgbase = lazyman-git
pkgdesc = A simple program that lets you stream every NHL and MLB game
- pkgver = 2.3.0.20180226
+ pkgver = 2.3.1.20180418
pkgrel = 1
url = https://github.com/StevensNJD4/LazyMan
install = lazyman.install
diff --git a/PKGBUILD b/PKGBUILD
index 30ed4552a1c9..5effc4395895 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: StevensNJD4 <github dot com slash StevensNJD4>
pkgname=lazyman-git
-pkgver=2.3.0.20180226
+pkgver=2.3.1.20180418
pkgrel=1
pkgdesc="A simple program that lets you stream every NHL and MLB game"
url="https://github.com/StevensNJD4/LazyMan"
@@ -38,8 +38,8 @@ pkgver() {
prepare() {
cd "$srcdir/LazyMan"
- patch -Np0 -i "../remove_privileged_actions.patch"
- patch -Np0 -i "../add_mlbnetwork.patch"
+ #patch -Np0 -i "../remove_privileged_actions.patch"
+ #patch -Np0 -i "../add_mlbnetwork.patch"
}
build() {
diff --git a/lazyman.install b/lazyman.install
index 517eef7ccdae..feea5079e385 100644
--- a/lazyman.install
+++ b/lazyman.install
@@ -1,10 +1,22 @@
post_install() {
- local ip=$(drill -4 freegamez.ga @8.8.8.8 A |grep ANSWER -A1 |awk '/freegamez.ga/ { print $5 }')
+ local site=(powersports.ml freegamez.ga)
+ local ip= i=0
+
+ until [[ $ip ]]; do
+ ip=$(drill -4 ${site[i]} @1.1.1.1 A |grep ANSWER -A1 |grep ${site[i]} |cut -dA -f2|sed 's/\t//')
+ ((i++))
+ if [[ $i -ge 2 ]]; then
+ echo " Error resolving hostnames: ${site[@]}"
+ exit
+ fi
+ done
+
if [[ ! $(grep "$ip" /etc/hosts) ]]; then
echo
echo " You must add the following lines to your /etc/hosts file"
echo " "$ip" mf.svc.nhl.com"
echo " "$ip" playback.svcs.mlb.com"
+ echo " "$ip" mlb-ws-mf.media.mlb.com"
echo
fi
}