summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-10-07 16:04:12 +0800
committerChocobo12020-10-07 16:06:49 +0800
commit0d52d54f426549fd510c08ac0bac95ae67b810d6 (patch)
tree2fca44b78c0b44fb192e2f347eb48bc89888bfea
parent76c3731e12cdb02ad2765bffe3fd2ed3f979b8a4 (diff)
downloadaur-0d52d54f426549fd510c08ac0bac95ae67b810d6.tar.gz
upgpkg: wdt-git 1.27.1612021.r162.gb585d21-2
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-compile-error.patch25
-rw-r--r--PKGBUILD12
3 files changed, 35 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3eb4108f1ac..3aa8e180a55e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wdt-git
pkgdesc = Tool to transfer data between 2 systems as fast as possible over multiple TCP paths
pkgver = 1.27.1612021.r162.gb585d21
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/facebook/wdt
arch = i686
arch = x86_64
@@ -21,8 +21,10 @@ pkgbase = wdt-git
conflicts = wdt
source = git+https://github.com/facebook/wdt.git
source = git+https://github.com/facebook/folly.git
+ source = 0001-Fix-compile-error.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 918c6454a3634348eb4308138b7b67d0f06985fa8ecab4909c3b4cebaa9a7663
pkgname = wdt-git
diff --git a/0001-Fix-compile-error.patch b/0001-Fix-compile-error.patch
new file mode 100644
index 000000000000..19d0e6fc9c73
--- /dev/null
+++ b/0001-Fix-compile-error.patch
@@ -0,0 +1,25 @@
+From 587eb38456106d09de3408c7edda93bbfdd7035d Mon Sep 17 00:00:00 2001
+From: Chocobo1 <Chocobo1@users.noreply.github.com>
+Date: Wed, 7 Oct 2020 16:06:14 +0800
+Subject: [PATCH] Fix compile error
+
+https://github.com/facebook/wdt/issues/199
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a061d93..578ca6c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -74,6 +74,7 @@ set (FOLLY_CPP_SRC
+ "${FOLLY_SOURCE_DIR}/folly/hash/detail/ChecksumDetail.cpp"
+ "${FOLLY_SOURCE_DIR}/folly/hash/detail/Crc32cDetail.cpp"
+ "${FOLLY_SOURCE_DIR}/folly/hash/detail/Crc32CombineDetail.cpp"
++"${FOLLY_SOURCE_DIR}/folly/lang/CString.cpp"
+ "${FOLLY_SOURCE_DIR}/folly/ScopeGuard.cpp"
+ )
+
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
index fb6d34ea0c85..aa5f7a44c49c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wdt-git
pkgver=1.27.1612021.r162.gb585d21
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to transfer data between 2 systems as fast as possible over multiple TCP paths"
arch=('i686' 'x86_64')
url="https://github.com/facebook/wdt"
@@ -14,15 +14,17 @@ checkdepends=('gtest')
provides=('wdt')
conflicts=('wdt')
source=("git+https://github.com/facebook/wdt.git"
- "git+https://github.com/facebook/folly.git")
+ "git+https://github.com/facebook/folly.git"
+ "0001-Fix-compile-error.patch")
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '918c6454a3634348eb4308138b7b67d0f06985fa8ecab4909c3b4cebaa9a7663')
prepare() {
- cd "folly"
+ cd "wdt"
- git checkout "$(git describe --abbrev=0 --always)"
+ patch -Np1 -i "$srcdir/0001-Fix-compile-error.patch"
}
pkgver() {